cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
324
Views
0
Helpful
2
Replies

load balance isdn & adsl

ddicky
Level 1
Level 1

I had tried to load balance or failover between an ISDN line and ADSL connection based on config below.It only work on ISDN line but once I used a single ADSL connection without the connection from ISDN it just work perfect.

Cisco1750#show run

Building configuration...

Current configuration : 1850 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco1750

!

boot-start-marker

boot-end-marker

!

enable password xxxxxx

!

memory-size iomem 25

no aaa new-model

ip subnet-zero

!

!

no ip domain lookup

!

ip cef

isdn switch-type basic-net3

!

!

!

!

interface BRI0

description connected to Internet

no ip address

ip nat outside

encapsulation ppp

dialer rotary-grou

dialer-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Ethernet0

ip address b.b.b.b 255.255.255.0 "global ip"

ip nat outside

half-duplex

!

interface FastEthernet0

description connected to EthernetLAN

ip address 192.168.x.x 255.255.255.0

ip nat inside

speed auto

!

interface Dialer1

description connected to Internet

ip address negotiated

ip nat outside

encapsulation ppp

no ip split-horizon

dialer in-band

dialer string 1525

dialer hold-queue 10

dialer-group 1

no cdp enable

ppp authentication c

ppp chap hostname abc

ppp chap password xxxxxx

ppp pap sent-username abc password xxxxx

!

router rip

version 2

passive-interface Dialer1

network 192.168.253.0

no auto-summary

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 102 interface Ethernet0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 b.b.b.b "gateway for the ADSL connection"

no ip http server

!

!

access-list 1 permit 192.168.x.x 0.0.0.255

access-list 102 permit ip 192.168.x.x 0.0.0.255 any

dialer-list 1 protocol ip permit

!

snmp-server xxxx

snmp-server enable traps tty

!

line con 0

exec-timeout 0 0

password xxxx

login

line aux 0

line vty 0 4

password xxxx

login

!

!

end

Cisco1750#

2 Replies 2

lgijssel
Level 9
Level 9

This is not a proper configuration; you should not have two default routes active at the same time.

This causes the following problems:

- Out of sequence packets.

- Inproper load balancing due to unequal cost paths.

- Extensive retransmission in case of lost packets.

Besides all this misery, it is very likely that your return path will be either ISDN or ADSL. Your load balancing will only work in one direction. Check it!

My advice would be to forget about load balancing in this situation. To get this working properly, you have to adjust the provider side as well.

Regards,

Leo

tekha
Level 3
Level 3

First replace this:

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 102 interface Ethernet0 overload

With this:

ip nat inside source route-map Ethernet0 interface Ethernet0 overload

ip nat inside source route-map Dialer1 interface Dialer1 overload

!

route-map Ethernet0 permit 10

match ip address 102

match interface Ethernet0

!

route-map Dialer1 permit 10

match ip address 102

match interface Dialer1

This should make the NAT work probably, if howerver your 2 default routes have the same administative distance, check by doing a "sh ip route".

You should see somthing like this:

S* 0.0.0.0/0 [1/0] via b.b.b.b, Ethernet0

[1/0] via d.d.d.d, Dialer1

This config will make equal load balancing over both lines, this works OK if both lines have the same bandwidth, however if you have 128 Kb on the ISDN and 256 on the ADSL you need to make it unequal load balancing using static routes.

I haven't done this myself, but I'm sure you can find it on the cisco page.

Good luck.

Review Cisco Networking for a $25 gift card