05-23-2004 10:52 PM - edited 03-02-2019 03:53 PM
I was wondering. Can i somehow change my bandwidth for a location and limit the bandwidth for another?
For example; 70% of my bandwidth goes to 192.168.x.x, and 30% goes to 192.168.y.y (x and y are different locations but both on the same interface (eth0) )
Is this possible on a Cisco 800 series router? thnx!
05-24-2004 01:46 AM
Try this:
The solution is CBWFQ in Cisco 827. ADSL over IP
!
class-map match-all BAJA
match access-group 152
class-map match-all ALTA
match access-group 150
class-map match-all MEDIA
match access-group 151
!
!
policy-map reparto-BW
class ALTA
bandwidth percent 55
class MEDIA
bandwidth percent 15
class BAJA
bandwidth percent 5
!
interface ATM0.1 point
service-policy output reparto-BW
!
access-list 150 .......
access-list 151 .........
access-list 152 ........
For example: C820-Y6-M Version 12.2(11)YV1 -->
flash:c820-y6-mz.122-11.YV1.bin
DRAM: 25Mbps
FLASH: 8Mpbs
05-24-2004 03:04 AM
woow going a bit fast m8.
How do i do all that? (commands)
Do i have to make those acces groups? (if yes; how?)
Here's the config of one router, maybe it will help. Thnx!!
Current configuration : 1428 bytes
!
version 12.2
no service pad
!
no logging buffered
!
ip subnet-zero
!
ip cef
!
!
!
interface Ethernet0
ip address 192.168.4.10 255.255.255.0
ip helper-address 192.168.1.5
no cdp enable
hold-queue 32 in
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 2/32
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex B
dsl linerate AUTO
!
interface Dialer0
ip unnumbered Ethernet0
no ip proxy-arp
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap refuse
ppp ipcp address accept
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
!
!
dialer-list 1 protocol ip permit
no cdp run
snmp-server community public RO
snmp-server community private RO
snmp-server enable traps snmp authentication linkdown link
snmp-server enable traps pppoe
snmp-server enable traps rtr
line con 0
exec-timeout 0 0
login
stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end
05-25-2004 10:22 PM
can anybody give me the easy commands (just a few examples??) Plz I need some help with this
05-26-2004 06:42 AM
I'm not a QoS guru but I'll build on Miguel's example as best as I can:
One thing I see is I don't see the two networks on your ethernet interface. (You may be adding a secondary IP later or something I guess).
Here are the ACLs to match on:
access-list 150 permit ip 192.168.x.x 0.0.255.255 any
access-list 151 permit ip 192.168.y.y 0.0.255.255 any
Here we classify the packets based on the ACLs above:
class-map match-all netxx
match access-group 150
class-map match-all netyy
match access-group 151
Here we allocate BW to each classification:
policy-map middee
class netxx
bandwidth percent 53
class netyy
bandwidth percent 22
class class-default
fair-queue
Note: The bandwidth (by default) can only = 75%. There is 25% reserved for link overhead. You can override this and use the bandwidth for your policy by using the max-reserved-bandwidth interface command.
Apply policy to pvc:
interface ATM0
pvc 2/32
service-policy output middee
-HTH
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide