06-18-2004 10:49 AM - edited 03-02-2019 04:29 PM
My company has just upgraded their 1760 router to use a WIC 1T DSU instead of an external CSU/DSU. However, with this new config, I am unable to make the dial backup modem kick in. I've tried manually shutting down the serial interface, pinging to bring up interesting traffic, reloading the router several times, and upgrading the IOS, but I'm still not having any luck. When I go back to my old config of using an external CSU/DSU with the same router, the modem DDR works perfectly fine. Any tips or suggestions? My config is below. Thanks in advance!
version 12.2
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname test
!
logging queue-limit 100
logging buffered 4096 debugging
enable secret 5
!
username cisco password
username c password
memory-size iomem 25
ip subnet-zero
!
!
no ip domain lookup
ip host c3 192.168.15.45
!
!
chat-script default ABORT ERROR ABORT BUSY ABORT "NO ANSWER" "" "ATDT\T" TIMEOUT 60 CONNECT \c
!
!
!
interface FastEthernet0/0
description connected to EthernetLAN
ip address
ip helper-address
speed auto
!
interface Serial0/0
description
no ip address
encapsulation frame-relay IETF
no ip mroute-cache
no fair-queue
service-module t1 timeslots 1-2
cdp enable
!
interface Serial0/0.1 point-to-point
ip address
frame-relay class LINKWATCH
frame-relay interface-dlci 53
!
interface Serial1/0
physical-layer async
description dial backup line
ip address
encapsulation ppp
dialer in-band
dialer idle-timeout 300
dialer map ip 192.168.45.9 name c modem-script default broadcast 13105551212
dialer hold-queue 10
dialer-group 1
no keepalive
cdp enable
ppp authentication chap
!
interface Serial1/1
no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.45.9 200
no ip http server
!
!
!
!
map-class frame-relay LINKWATCH
frame-relay end-to-end keepalive mode request
dialer-list 1 protocol ip permit
!
snmp-server community public RO
snmp-server packetsize 2048
snmp-server enable traps tty
banner motd ^CCCCCCC
\\\///
/ _ _ \
(| (.)(.) |)
-----------------.OOOo--()--oOOO.--------------------------------
------------------.oooO------------------------------------------
( ) Oooo.
\ ( ( )
\_) ) /
(_/
^C
!
line con 0
exec-timeout 0 0
login local
line 2
flush-at-activation
modem InOut
modem autoconfigure type usr_sportster
transport input all
stopbits 1
speed 57600
flowcontrol hardware
line aux 0
login local
modem InOut
modem autoconfigure type usr_sportster
speed 57600
flowcontrol hardware
line vty 0 4
login local
!
no scheduler allocate
ntp clock-period 17178900
ntp peer 192.168.3.4
end
06-18-2004 11:12 AM
Hello,
can you post the output of:
debug dialer events
debug ppp negotiation
debug ppp authentication
By the way, did this configuration work as is with the external DSU/CSU ? I can see only a default route pointing to the async line, and no default route to anything else. Also, if you place the command:
backup interface serial 1/0
in the Serial0/0.1 config, the backup line automatically kicks in when the main line goes down.
Regards,
Georg
06-18-2004 01:05 PM
Georg,
The config I used for the external DSU/CSU is practically the same as the one I posted except that there isn't a WIC 1T DSU interface (Serial 0). I used the "backup interface serial1/0" command on the serial0/0.1 interface (as you suggested) but when I bring the main link down, I get a message saying:
Interface serial1/0, changed state to standby mode/disable
The modem doesn't try to dial out. And I don't see any debug outputs. Any other suggestions? Thanks for all your help.
06-18-2004 01:17 PM
Hello,
just to be sure, how do you bring down the primary line ? I guess you are aware that administratively shutting down the line will not work, this is Cisco-specifc I guess, the backup interface does not consider this a failure. You will need to unplug the cable. If you have done that and it still does not work, can you post the output of the debugs mentioned earlier ?
Regards,
Georg
06-18-2004 01:35 PM
Georg,
Here's my output when I unplugged the cable to the main link.
*Mar 1 00:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
*Mar 1 00:50:52: Se1/0 DDR: re-enable timeout
g620#
*Mar 1 00:53:22: %LINK-3-UPDOWN: Interface Serial0/0, changed state to down
The modem just won't dial out. I have no problems at all with an external DSU/CSU.
06-21-2004 06:45 AM
Georg,
Turns out that I didn't have a default route pointing to serial1/0 (backup interface). Thanks for all your help!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide