cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6907
Views
0
Helpful
3
Replies

multiple route map policies on 1 interface

universal
Level 1
Level 1

can more than 1 route map be applied to an interface?

I am using IOS version 12.3(11)T3. Thank you in advance.

3 Replies 3

Richard Burts
Hall of Fame
Hall of Fame

From the title of your question I assume that you are talking about using Policy Based Routing. I believe that in PBR that there can be only one route map assigned to an interface.

Within the route map there can be multiple instances which does give you the ability to define multiple policies to implement on the interface.

If you could be a bit more clear about what you are trying to accomplish perhaps we could give you better advice.

HTH

Rick

HTH

Rick

I have a T1 and a cable modem at my facility. I originally put a route map on int gige0/0 (internal network) for http traffic only because the cable modem is faster. I then decided to implement a failover solution between the T1 and the cable modem. First I enabled PBR with multiple tracking options so a service provider failure would be invisible to the end user. I added another route map policy to the intgige0/0 to permit any ip traffic in the event of one of my service providers failing. How does this affect my original http policy?

Here is part of the config:

access-list 110 permit ip any any

access-list 111 permit tcp any any eq www

access-list 111 permit udp any any eq 80

no cdp run

!

route-map http_policy permit 10

match ip address 111

set ip next-hop xxx.xxx.xxx.xxx

!

route-map http_policy permit 20

!

route-map alpha permit 10

set ip next-hop verify-availability xxx.xxx.xxx.xxx 10 track 123

set ip next-hop verify-availability xxx.xxx.xxx.xxx 20 track 124

!

route-map alpha permit 20

match ip address 110

Thank you.

Edward

I am beginning to understand better but still find some parts of your situation to be puzzling. It would help if you also posted the configuration of the gig0/0 interface. From the explanation I believe that the gig 0/0 interface originally had ip policy route-map http_policy and now it has ip policy route-map alpha. If that is the case then you replaced the original route map with the new route map since the interface can have only one policy route map.

Your explanation is made slightly more difficult to understand because you have obscured all IP addresses with xxx so it is a bit hard to understand what the various parts of the various route maps are trying to do.

I find route map alpha to be a bit strange and suspect that it is not doing quite what you had in mind. the first instance (permit 10) has no match clause so everything will be considerred a match and the set next hop will apply. There will be nothing to get to the second instance (permit 20).

If I understand you objectives then I believe that you want to create a single route map that combines logic from the two route maps you have created so far. In this explanation assume that ccc is the next hop of the cable modem and ttt is the next hop of the T1. I think you need only access list 111. The combined route map would look something like this:

route-map new_policy permit 10

match ip address 111

set ip next-hop ccc

!

route-map new_policy permit 20

set ip next-hop verify-availability ttt 10 track 123

set ip next-hop verify-availability ccc 20 track 124

There is another possibility that you might consider depending on how you have established default routes. You might accomplish your objective by establishing a default route to one interface, establishing a floating static route with object tracking on the original default route to detect failure and invoke the floating static and use the original route map to steer http traffic to the other interface.

HTH

Rick

HTH

Rick