cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1826
Views
0
Helpful
0
Replies

police-aggregate policer : 6509e

JMCNEL
Level 4
Level 4

before had to aggregate traffic to 5 mbps

mls qos aggregate-policer ip_5_mbps 5000000 25000 25000 conform-action transmit exceed-action drop

now has to increase to 30mbps

want to make sure that I have the calculations correctly

i found some documentation on cisco's website stating that the calculation is as follow



mls qos aggregate-policer ip_30_mbps 30000000 xxxx xxxxx conform-action transmit exceed-action drop

  • Burst = (1,000,000 bps * 0.00025) or (1518 bytes * 8 bits/byte) = 250 or 12144.


The larger result is 12144, which you round to 13 kbps.

so in my case it would be 30000000*0.00025=7500 - which is smaller than 12144 so would my command look like

mls qos aggregate-policer ip_30_mbps 30000000 12144 7500 conform-action transmit exceed-action drop

but also found documentation that states to do the calculation as follow

normal burst = (30000000/8)*1.5=5625000

extended burst will be 5625000*0,2=1125000

and my command looks like this

mls qos aggregate-policer ip_30_mbps 30000000 5625000 1125000 conform-action transmit exceed-action drop

so which one is the correct one?



class-map match-all

class-internetcityaggregate_30_mbps

match access-group name

internet-city-aggregate_30_mbps

class-map match-all

class-cityaggregate_30_mbps

match access-group name

city-aggregate_30_mbps

!

policy-map

policy-internetcityaggregate_30_mbps

class

class-internetcityaggregate_30_mbps

police aggregate

ip_30_mbps

policy-map policy-cityaggregate_30_mbps

class

class-cityaggregate_30_mbps

police aggregate

ip_30_mbps

 

interface Vlan101

description INTERNET

ip address x.x.x.x 255.255.0.0

service-policy input

policy-internetcityaggregate_30_mbps

service-policy output policy-cityaggregate_30_mbps

!

ip access-list extended

city-aggregate_30_mbps

deny ip any 10.x.0.0 0.0.255.255

permit ip 10.x.0.0 0.0.255.255 any

permit ip 10.x.0.0 0.0.255.255 any

deny ip any any

ip access-list extended

internet-city-aggregate_30_mbps

deny ip 10.x.0.0 0.0.255.255 any

permit ip any 10.x.0.0 0.0.255.255

permit ip any 10x.0.0 0.0.255.255

permit ip any 10.x.0.0 0.0.255.255

deny ip any any

!



0 Replies 0