cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
263
Views
0
Helpful
1
Replies

Qos : Depoly Priority Queue on Cat6500

johnyoon75
Level 1
Level 1

Hello.

I'm gonna deploy qos policy including priority queue on cat6500 for Voip , Vide, and Multicat.

The module's capability(WS-6408A-GBIC)is 1p2q2t.

So i'll assign Priory queue for Voip and Video.

I already had make configuration as below.

Please check the configuration for depolying pririty queue on cat6500

regard.

john.

!

class-map match-all voicedata

match access-group name voice

class-map match-all videodata

match access-group name video

class-map match-all multi

match access-group name multicast-1

!

policy-map voicemark

class voicedata

set dscp ef

policy-map videomark

class videodata

set dscp ef

policy-map multimark

class multi

set dscp af41

!

interface GigabitEthernet7/7

description << Voice Gateway >>

ip address 192.168.1.1 255.255.255.0

service-policy input voicemark

!

interface GigabitEthernet9/14

description << Multicast Server >>

no ip address

mls qos vlan-based

switchport

switchport access vlan 100

switchport mode access

!

ip access-list extended voice

permit ip host 172.30.254.2 any

!

ip access-list extended video

permit udp any any range 16384 32767

permit ip host 172.30.254.66 any

!

ip access-list extended multicast-1

permit ip any host 239.66.11.11

!

============================================

I'm gona add follow config for priority queue

6500#sh int gi 7/7 capabilities

GigabitEthernet7/7

Model: WS-X6408A-GBIC

Type: 1000BaseSX

Speed: 1000

Duplex: full

Trunk encap. type: 802.1Q,ISL

Trunk mode: on,off,desirable,nonegotiate

Channel: yes

Broadcast suppression: percentage(0-100)

Flowcontrol: rx-(off,on,desired),tx-(off,on,desired)

Membership: static

Fast Start: yes

QOS scheduling: rx-(1p1q4t), tx-(1p2q2t)

CoS rewrite: yes

ToS rewrite: yes

Inline power: no

SPAN: source/destination

UDLD yes

Link Debounce: yes

Link Debounce Time: yes

Ports on ASIC: 1-8

6500#

6500(config)#mls qos map cos-dscp 0 8 16 26 34 46 48 56

6500(config-if)#priority-queue cos-map 1 5

1 Reply 1

ssoberlik
Level 4
Level 4

The following are the configuring QOS manually

interface Multilink1

ip address 10.1.61.1 255.255.255.0

ip tcp header-compression iphc-format

load-interval 30

service-policy output QoS-Policy

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

multilink-group 1

ip rtp header-compression iphc-format

!

interface Serial0

bandwidth 256

no ip address

encapsulation ppp

no ip mroute-cache

load-interval 30

no fair-queue

ppp multilink

multilink-group 1

class-map VoIP-RTP

match access-group 100

!

class-map VoIP-Control

match access-group 101

!

policy-map QoS-Policy

class VoIP-RTP

priority 100

!

class VoIP-Control

bandwidth 8

!

class class-default

fair-queue

access-list 100 permit ip any any precedence 5

access-list 100 permit ip any any dscp ef

access-list 101 permit tcp any host 10.1.10.20 range 2000 2002

access-list 101 permit udp any host 10.1.10.20 2427

access-list 101 permit tcp any host 10.1.10.20 2428

!

access-list 101 permit tcp any host 10.1.10.20 1720

access-list 101 permit tcp any host 10.1.10.20 range 11000 11999