09-11-2002 12:40 PM - edited 03-02-2019 01:17 AM
Hi,
I have an AS5300 remote access server with 48 modems. I have a problem when an ISDN connection is made to the remote access server. The remote user gets authenicated to the server but when it tries to bundle the second line it discconnects the remote user. When I try with two analog modem connection it also errors after authenication when it tries to bundle the two lines together. I have a virtual-template configured on the server with ppp multilink. I have a dialer group with ppp multilink configured to it. Any thoughts on why this would happen on the bundling portation of the condition? Authenication is fine for users who connection on a single link 56k connection.
09-12-2002 08:12 AM
We need to see the following debug on the router which is receiving the call
debug isdn q931
debug ppp nego
debug ppp multi
debug aaa authorization
Also here is a url with sample config in that regards..
http://www.cisco.com/warp/public/793/access_dial/5300.html
and
http://www.cisco.com/warp/public/793/access_dial/async_multilink.html
09-12-2002 09:17 AM
When I look at the second config my serial 0:23 does not have ppp multilink . When I try to add it I get an error that I can't change ppp values of a hunt group
member.
Debug:
Here is the debug for it:
23:16:32.626: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x01C1
23:16:32.626: Bearer Capability i = 0x8890
23:16:32.626: Channel ID i = 0xA98393
23:16:32.626: Calling Party Number i = '!', 0x81, '2625229082'
23:16:32.626: Called Party Number i = 0x80, '1011'
23:16:32.634: %LINK-3-UPDOWN: Interface Serial0:18, changed state to up
23:16:32.638: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x81C1
23:16:32.638: Channel ID i = 0xA98393
23:16:32.638: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x81C1
23:16:32.638: Channel ID i = 0xA98393
23:16:32.666: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x01C1
23:16:34.442: %ISDN-6-DISCONNECT: Interface Serial0:18 disconnected from
9082 ventisdn, call lasted 1 seconds
23:16:34.442: ISDN Se0:23: TX -> DISCONNECT pd = 8 callref = 0x81C1
23:16:34.442: Cause i = 0x8090 - Normal call clearing
23:16:34.486: ISDN Se0:23: RX <- RELEASE pd = 8 callref = 0x01C1
23:16:34.494: %LINK-3-UPDOWN: Interface Serial0:18, changed state to down
23:16:34.498: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x81C1
Here is my show run
User Access Verification
smithbrothers#show running
Building configuration...
Current configuration:
!
! Last configuration change at 06:17:06 CDT Fri Oct 24 2001 by jwise
!
version 11.3
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname smithbrothers
!
aaa new-model
aaa authentication login default tacacs+ local
aaa authentication login no_tacacs local
aaa authentication ppp default if-needed tacacs+ local
aaa authorization exec default local
aaa authorization network default tacacs+
aaa accounting exec default start-stop tacacs+
aaa accounting network default start-stop tacacs+
enable secret xxxxxxxxxxxxx
enable password xxxxxxxxxxxxxxxxx
!
username xxxxxxxxxxxxxxxx
username xxxxxxxxxxxxxx
username xxxxxxxxxxxxx
ip name-server x.x.x.x
ip name-server x.x.x.x
multilink virtual-template 1
async-bootp dns-server x.x.x.x
isdn switch-type primary-ni
clock timezone CDT -6
clock calendar-valid
!
!
controller T1 0
framing esf
clock source line primary
linecode b8zs
pri-group timeslots 1-24
!
controller T1 1
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-24
!
controller T1 2
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-24
!
controller T1 3
shutdown
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-24
!
!
interface Loopback0
ip address x.x.x.x x.x.x.x
!
interface Tunnel1
no ip address
ip mtu 1476
!
interface Ethernet0
no ip address
shutdown
!
interface Virtual-Template1
ip unnumbered Loopback0
no ip directed-broadcast
peer default ip address pool default
ppp authentication chap pap ms-chap
ppp multilink
!
interface Serial0:23
no ip address
encapsulation ppp
no ip route-cache
no keepalive
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-ni
isdn incoming-voice modem
no fair-queue
no cdp enable
!
interface Serial1:23
no ip address
encapsulation ppp
no ip route-cache
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-ni
isdn incoming-voice modem
no fair-queue
no cdp enable
!
interface Serial2:23
no ip address
encapsulation ppp
no ip route-cache
no keepalive
shutdown
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-ni
isdn incoming-voice modem
no fair-queue
no cdp enable
!
interface Serial3:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-5ess
isdn incoming-voice modem
no fair-queue
no cdp enable
!
interface FastEthernet0
ip address x.x.x.x x.x.x.x
no ip mroute-cache
!
interface Group-Async1
ip unnumbered FastEthernet0
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 1800
dialer-group 1
async mode interactive
peer default ip address pool default
no fair-queue
no cdp enable
ppp authentication pap chap ms-chap
ppp timeout retry 5
group-range 1 48
!
interface Dialer1
ip unnumbered FastEthernet0
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer in-band
dialer idle-timeout 86400
dialer-group 1
peer default ip address pool default
no fair-queue
no cdp enable
ppp authentication pap chap ms-chap
ppp multilink
ppp multilink interleave
!
ip local pool default x.x.x.x x.x.x.x
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
no logging console
access-list 101 permit ip any any
access-list 199 permit icmp any any
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
tacacs-server host x.x.x.x
tacacs-server timeout 25
tacacs-server key eyecom
tacacs-server dns-alias-lookup
snmp-server community public RO
!
line con 0
exec-timeout 0 0
logging synchronous
login authentication no_tacacs
line 1 48
autoselect during-login
autoselect ppp
modem InOut
modem autoconfigure discovery
transport input all
line aux 0
line vty 0 4
login authentication no_tacacs
!
scheduler interval 1000
end
09-18-2002 02:39 PM
The debug is inconclusive; add "debug ppp neg" for starters, to see what that indicates.
The "multilink virtual-template 1" command is really only needed for leased interfaces; you can just as easily configure all the VT stuff under the dialer interface (change the autentication and IP address of the dialer to be similar to the VT, then remove the VT). Don't worry about MPPP under the serial interface, it's not needed with the rotary group. For async users you would need to add MPPP to the group-async interface.
If the PPP debug does not seem to be completely helpful, then add "debug aaa authen" and "debug aaa author" to the mix.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide