06-22-2004 02:34 AM - edited 03-02-2019 04:32 PM
Hi
Is there any command that will show the routing of specific traffic out a designated interface (HTTP out adsl interface - All other traffic is sent out Serial line? I have attached my config file to explain what I am trying to achieve :-
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
pvc 0/50
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet0
ip address x.x.x.x x.x.x.x speed auto
!
interface Serial0
description Leased Line To (ISP)
ip address x.x.x.x x.x.x.x
ip policy route-map Everything_But_WWW
!
interface Dialer1
ip address negotiated
encapsulation ppp
ip policy route-map Port_80_Out
shutdown
dialer pool 1
ppp pap sent-username ialdxb password 7
!
ip default-gateway serial S0 - next hop
ip classless
ip route 0.0.0.0 0.0.0.0 S0
no ip http server
!
!
access-list 101 remark Port_80_Out
access-list 101 permit tcp host x.x.x.x eq www any
access-list 101 permit tcp host x.x.x.x eq 8080 any
access-list 102 remark Everything_But_WWW
access-list 102 permit ip host x.x.x.x any
route-map Everything_But_WWW permit 10
match ip address 102
set interface Serial0
set ip precedence immediate
set default interface Serial0
!
route-map Port_80_Out permit 10
match ip address 101
set interface Dialer1
set ip precedence priority
set default interface Dialer1
!
!
Cheers
Glen
06-22-2004 03:46 AM
Glen
I would suggest setting them all against the fast ethernet interface rather than the outbound interfaces. This way, when the packets arrive at the router, it sends them to the correct interface. Sorry can't actually give the answer regarding routing. The only way would be to watch the counters on the ACLs.
06-22-2004 03:54 AM
Hi pdoyle
Thanks for your thoughts on this, I will give it a try and let you know the outcome...Cheers Glen
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide