04-08-2003 11:50 PM - edited 03-02-2019 06:31 AM
Hello colleagues,
I am trying to set up rsh on one of my routers in order for a user on another router to execute certain 'show' commands. I keep getting a Permission Denied message, and I think I am missing something basic here. I want a user on router1 to execute commands on router2. This is what my config looks like:
router2
ip rcmd rsh-enable
ip rcmd remote-host router2 172.16.12.1 (this is the IP address of router1) user enable 15
This is what I execute on router1:
router1
rsh router2 /user user sh run
This is when I get the error message saying Permission Denied. I think I am missing the concept. Can anybody tell me what the config of both routers should look like in order for router1 to execute commands on router2 ?
Thanks in advance for your help.
Regards,
Georg
04-15-2003 07:06 AM
Try the following configuration :
Router1#sh run
Building configuration...
Current configuration : 859 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router1
!
enable password
!
username dummy password 0 test
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 10.0.0.1 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
ip http server
ip pim bidir-enable
!
!
!
line con 0
logging synchronous
login local
line aux 0
line vty 0 4
no login
!
end
Router2#show run
Building configuration...
Current configuration : 638 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
!
ip subnet-zero
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host Router1 10.0.0.1 dummy enable
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
no fair-queue
clockrate 64000
!
interface Serial1
ip address 10.0.0.2 255.255.255.0
!
interface BRI0
no ip address
shutdown
!
!
ip classless
ip http server
ip pim bidir-enable
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
Login to device Router1 with the username 'dummy' and execute the command '
rsh 10.0.0.2 /user Router1 show run ' . You should see the following :
Router1 con0 is now available
Press RETURN to get started.
User Access Verification
Username: dummy
Password:
Router1>en
Password:
Router1#
Router1#rsh 10.0.0.2 /user Router1 show run
Building configuration...
Current configuration : 638 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
!
ip subnet-zero
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host Router1 10.0.0.1 dummy enable
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
no fair-queue
clockrate 64000
!
interface Serial1
ip address 10.0.0.2 255.255.255.0
!
interface BRI0
no ip address
shutdown
!
!
ip classless
ip http server
ip pim bidir-enable
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide