cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
332
Views
0
Helpful
2
Replies

Two WAN interface problem

snaffin123
Level 1
Level 1

Hello

I am having a problem utilizing two WAN interfaces on our Cisco 1760 router (with a 4-port switched WIC Card). Here is a description of our setup (IP addresses have been changed to protect the guilty):

interface FastEthernet0/0

description SBC WAN Interface (Static "Sticky" IP)

ip address 172.1.1.193 255.255.255.240

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface FastEthernet0/1

switchport access vlan 2

no ip address

!

interface FastEthernet0/2

switchport access vlan 3

no ip address

!

interface FastEthernet0/3

switchport access vlan 4

no ip address

!

interface FastEthernet0/4

switchport access vlan 5

no ip address

shutdown

!

interface Vlan1

no ip address

!

interface Vlan2

description Internal Network

ip address 192.168.0.1 255.255.255.0

ip nat inside

!

interface Vlan3

description Covad WAN Interface (Standard Static IP)

ip address 172.1.2.210 255.255.255.240

ip nat outside

!

interface Vlan4

description DMZ Interface

ip address 192.168.50.1 255.255.255.0

ip nat inside

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username <username> password 0 <passwd>

!

!

ip classless

! Default route using Covad Interface

ip route 0.0.0.0 0.0.0.0 172.1.2.209

! Default route using SBC Interface

! ip route 0.0.0.0 0.0.0.0 Dialer1

Here is the problem... If I set the default route to the Covad Interface (IP 172.1.2.209) then I can ping the covad interface but not the SBC. If I switch the default route to use the SBC interface then I can ping the SBC IP but not the Covad interface. If I have both then the first default route listed will be used and the other will not work. I tried route-maps but with no success as well. I probably should mention the the FastEthernet0/0 interface is attached to a Westell ADSL modem while the FastEthernet0/2 interface is attached to a Efficient Networks ASDL Modem/Router. Any help would be appreciated.

2 Replies 2

mheusinger
Level 10
Level 10

Well it looks like you have two different static routes, one to an IP another pointing to an interface.

The administrative distance is different then, i.e. AD=0 for static to interface and AD=1 for static to next hop IP.

Try using two next hops or two interfaces or

ip route 0.0.0.0 0.0.0.0 Dialer1 1

where 1 is the administrative distance.

This should insert both of the default routes into therouting table and allow for loadsharing, if this is what you want to achieve.

regards

Martin

vcjones
Level 5
Level 5

You've got several problems with your configuration, and I don't think you're going to like the answer...

As Marvin pointed out, as configured, the default route to SBC is a "connected route" and will have a lower administrative distance than the default route to Covad. As a result, traffic will always go out the SBC link and the Covad link will be idle unless you "shut" the Dialer interface (dialer interfaces are always up, so you can't use loss of the PPPoE session to signal loss of the route).

Simply making both routes equal admin difference by pointing the SBC default route at an IP address rather than the Dialer interface, assuming you can even do so, is not going to do the job. Since you are using NAT, you need to make sure that all the traffic associated with any specific session, such as a TCP connection, always uses the same provider.

You may be able to use route maps to do the job (such as by having one inside IP use Covad and the other use SBC), depending upon what your inside looks like. But that still does not provide a way to detect when the link to one provider or the other fails. That requires the use of "ping base routing" (search for response time recorder or rtr on www.cisco.com).

Once you have the ability to change route based on availability of service providers, you then need to figure out how to clear all the NAT translations for the link which has gone down. Otherwise your traffic will be cheerfully routed out to the working ISP using the NAT for the disfunctional ISP. You can work around that limitation using ESM, but programming that in TCL on a Cisco router is not for the feint of heart.

If you really want to use both links at the same time from the same inside IP address, and fail over automatically if one link should fail, look at SOHO routers like the Symantec 200R or LinkSys RV042 which have the capability to route over unrouteable networks built in.

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com