cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
313
Views
0
Helpful
2
Replies

XP Remote Desktop through 2621

cdebouche
Level 1
Level 1

I have a 2621 router running ios 12.2. It is configured and running great, all workstations can access the internet. My problem is that I am unable to connect to a workstation (192.168.1.3) on the inside. I am trying to connect to this workstation from outside the office. I have dug around the forums and tried a few things to get port 3389 from the WAN to "redirect" to a local machine (192.168.1.3) at port 3389. Incase my description isn't detailed enough here is a picture! :-)

INTERNET(public) ---> ROUTER --> WORKSTATION(private)

Also the WAN address is assigned via DHCP, it is connected to a cable modem and it only provides one public IP.

Here is the config I am running, I changed the security related entries. Any help on this would be greatly appreciated.

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Area88Router

!

enable password ******

!

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool 192lan

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 63.240.76.19 204.127.198.19

lease infinite

!

ip audit notify log

ip audit po max-events 100

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

ip nat inside source list 100 interface FastEthernet0/0 overload

ip classless

no ip http server

ip pim bidir-enable

!

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

!

line con 0

password ********

line aux 0

line vty 0 4

password ********

login

!

end

Thank you in advance,

Chad

2 Replies 2

bwalchez
Level 4
Level 4

I don't think XP's remote desktop will work through a Port translatted NAT address. You might check with Microsoft support on this to be sure.

Find out the port number and protocol, udp or tcp and put in a line like this

ip nat inside source static mmm x.x.x.x yyyy interface Ethernet0 aaaa

mmm = udp or tcp

x.x.x.x = the ip of the computer you want to connect to (inside private address)

yyyy = the port number (for the inside)

ethernet0 = the interface that is on the outside (this could be a serial port)

aaaa = the port on the outside (probally the same as the inside or yyyy)

Then you use your public ip address when connecting from outside the network, this statement will redirect the connection to the inside computer you specified.