cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
831
Views
0
Helpful
6
Replies

How to use HSRP-Network redundency/Reliable Network solution

siskum
Spotlight
Spotlight

Configure HSRP-Hot Standby Roter Protocol (Network redundency or Reliable Network solution)

R3 Running Configuration

R3#config t

R3(config)#
R3(config)#int g0/0
R3(config-subif)#ip address 10.35.20.1 255.255.255.0
R3(config-subif)#no shutdown
R3(config-subif)#exit
R3(config)#
R3(config)#int g0/1
R3(config-subif)#no shutdown
R3(config-subif)#exit
R3(config)#
R3(config)#int g0/1.10
R3(config-subif)#encapsulation dot1Q 10
R3(config-subif)#ip address 10.35.10.1 255.255.255.0
R3(config-subif)#standby 10 ip 10.35.10.10
R3(config-subif)#standby 10 priority 140
R3(config-subif)#standby 10 preempt
R3(config-subif)#exit
R3(config)#
R3(config)#int g0/1.30
R3(config-subif)#encapsulation dot1Q 30
R3(config-subif)#ip address 10.35.30.1 255.255.255.0
R3(config-subif)#standby 30 ip 10.35.30.30
R3(config-subif)#standby 30 priority 140
R3(config-subif)#standby 30 preempt
R3(config-subif)#exit
R3(config)#ip route 10.35.10.0 255.255.255.0 g0/1.10
R3(config)#ip route 10.35.30.0 255.255.255.0 g0/1.30
R3(config)#ip dhcp pool net10
R3(dhcp-config)#network 10.35.10.0 255.255.255.0
R3(dhcp-config)#default-router 10.35.10.1

R3(dhcp-config)#default-router 10.35.10.10
R3(dhcp-config)#exit
R3(config)#ip dhcp pool net30
R3(dhcp-config)#network 10.35.30.0 255.255.255.0
R3(dhcp-config)#default-router 10.35.30.1

R3(dhcp-config)#default-router 10.35.30.30
R3(dhcp-config)#exit
R3(config)#

 

R3>enable
R3#sh Run
Building configuration...

Current configuration : 1240 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
ip dhcp pool Net10
network 10.35.10.0 255.255.255.0
default-router 10.35.10.1

default-router 10.35.10.10
ip dhcp pool Net30
network 10.35.30.0 255.255.255.0
default-router 10.35.30.1

default-router 10.35.30.30
!
interface GigabitEthernet0/0
ip address 10.35.20.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.35.10.1 255.255.255.0
standby 10 ip 10.35.10.10
standby 10 priority 140
standby 10 preempt
!
interface GigabitEthernet0/1.30
encapsulation dot1Q 30
ip address 10.35.30.1 255.255.255.0
standby 30 ip 10.35.30.30
standby 30 priority 140
standby 30 preempt
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 10.35.10.0 255.255.255.0 GigabitEthernet0/1
ip route 10.35.30.0 255.255.255.0 GigabitEthernet0/1.30
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

R4 Running Configuration

R4#config t
R4(config)#
R4(config)#int g0/0
R4(config-subif)#ip address 10.35.20.2 255.255.255.0
R4(config-subif)#no shutdown
R4(config-subif)#exit
R4(config)#
R4(config)#int g0/1
R4(config-subif)#no shutdown
R4(config-subif)#exit
R4(config)#
R4(config)#int g0/1.10
R4(config-subif)#encapsulation dot1Q 10
R4(config-subif)#ip address 10.35.10.2 255.255.255.0
R4(config-subif)#standby 10 ip 10.35.10.10
R4(config-subif)#standby 10 priority 140

R4(config-subif)#standby 10 priority 120
R4(config-subif)#standby 10 preempt
R4(config-subif)#exit
R4(config)#
R4(config)#int g0/1.30
R4(config-subif)#encapsulation dot1Q 30
R4(config-subif)#ip address 10.35.30.2 255.255.255.0
R4(config-subif)#standby 30 ip 10.35.30.30
R4(config-subif)#standby 30 priority 140

R4(config-subif)#standby 30 priority 120
R4(config-subif)#standby 30 preempt
R4(config-subif)#exit
R4(config)#
R4(config)#ip route 10.35.10.0 255.255.255.0 g0/1.10
R4(config)#ip route 10.35.30.0 255.255.255.0 g0/1.30
R4(config)#ip dhcp pool net10
R4(dhcp-config)#network 10.35.10.0 255.255.255.0
R4(dhcp-config)#default-router 10.35.10.2

R4(dhcp-config)#default-router 10.35.10.10
R4(dhcp-config)#exit
R4(config)#ip dhcp pool net30
R4(dhcp-config)#network 10.35.30.0 255.255.255.0
R4(dhcp-config)#default-router 10.35.30.2

R4(dhcp-config)#default-router 10.35.30.30
R4(dhcp-config)#exit
R4(config)#

R4#
R4#sh run
R4#sh running-config
Building configuration...

Current configuration : 1183 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
ip dhcp pool net10
network 10.35.10.0 255.255.255.0
default-router 10.35.10.2

default-router 10.35.10.10
ip dhcp pool net30
network 10.35.30.0 255.255.255.0
default-router 10.35.30.2

default-router 10.35.30.30
!
interface GigabitEthernet0/0
ip address 10.35.20.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.35.10.2 255.255.255.0
standby 10 ip 10.35.10.10
standby 10 priority 140

standby 10 priority 120
standby 10 preempt
!
interface GigabitEthernet0/1.30
encapsulation dot1Q 30
ip address 10.35.30.2 255.255.255.0
standby 30 ip 10.35.30.30
standby 30 priority 140

standby 10 priority 120
standby 30 preempt
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

SW2 running configuration

SW2#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#int g0/1
SW2(config-if)#sw
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport trunk allowed vlan 10,30
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#int g0/2
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport trunk allowed vlan 10,30
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#int range f0/1-12
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#int range f0/13-24
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#

SW1>enable
SW1#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)#host
SW1(config)#hostname SW2
SW2(config)#exit
SW2#
%SYS-5-CONFIG_I: Configured from console by console

SW2#
SW2#
SW2#sh run
Building configuration...

Current configuration : 2448 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access

!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
!
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
!
interface FastEthernet0/13
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 30
switchport mode access
!
!
!
interface FastEthernet0/22
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 30
switchport mode access
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 10,30
switchport mode trunk
!
interface GigabitEthernet0/2
switchport access vlan 10
switchport trunk allowed vlan 10,30
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end

Sisira
2 Accepted Solutions

Accepted Solutions

Hello,

the configs don't look right. To start out, the default routers defined in the DHCP pools need to be the standby IP address(es):

ip dhcp pool Net10
network 10.35.10.0 255.255.255.0
default-router 10.35.10.10
ip dhcp pool Net30
network 10.35.30.0 255.255.255.0
default-router 10.35.30.30

View solution in original post

I agree with @georg that the biggest issue is that the default router in the dhcp pools should be the virtual/HSRP address and not the IP assigned to the interface. I would also point out that the static routes for the local networks are not necessary. There will be entries in the routing table for those subnets as locally connected subnets, so the static routes serve no purpose.

I would also point out that the HSRP configuration specifies priority of 140 on both HSRP peers. When you specify priority you generally want to make one peer higher and the other peer lower. If you are going to make them the same then why specify priority at all?

HTH

Rick

View solution in original post

6 Replies 6

Hello,

the configs don't look right. To start out, the default routers defined in the DHCP pools need to be the standby IP address(es):

ip dhcp pool Net10
network 10.35.10.0 255.255.255.0
default-router 10.35.10.10
ip dhcp pool Net30
network 10.35.30.0 255.255.255.0
default-router 10.35.30.30

I agree with @georg that the biggest issue is that the default router in the dhcp pools should be the virtual/HSRP address and not the IP assigned to the interface. I would also point out that the static routes for the local networks are not necessary. There will be entries in the routing table for those subnets as locally connected subnets, so the static routes serve no purpose.

I would also point out that the HSRP configuration specifies priority of 140 on both HSRP peers. When you specify priority you generally want to make one peer higher and the other peer lower. If you are going to make them the same then why specify priority at all?

HTH

Rick

Hello Rick!

Thanks for both of you. I uppdated that Standby priority value one is higher than other. 

I set static route for future extend of net work to connect to internet access. Now a days thereis CISCO routers inbuilt EIGRP and OSPF routing protocols therefore not neccessay to add static route anymore. CISCO owned EIGRP working perfectly with sortest distance value with 90.

Your valueble comments always welcome.

Regards,

Sisira

Sisira

Sisira

I am glad that our suggestions have been helpful. Configuring priority is not required. So if you want to configure this parameter you would want it to have some effect. Making the priority of one peer higher than the other allows you to specify which peer will normally be the active peer.

Yes there are many alternatives for configuring routing information. Static routes are generally used less than the dynamic routing protocols. My point was that a static route for a subnet or network that is locally connected has no effect because a locally connected route is always preferred to any other type of route.

Thank you for marking this question as solved. This will help other participants in the community to identify discussions which have helpful information. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.

HTH

Rick

Hello Rick!

Yes you are exactly correct and I agree with your point, the "Standby Priority" not neccesary to configure in other router. When the primary "Priority" router down(fail) state then the other router will be changed it status from "standby" by to "Active".

Soon I will upload an other network configuration, why it is important dynamic IP routing such that EIGRP and OSPF.

Regards,

Sisira

Sisira

Hello Georg!

I understood that what you have pointed out. I corrected accordingly.

Sisira
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: