07-05-2005 04:50 PM - edited 03-02-2019 11:17 PM
I have a 3560 with 3 VLan and 3 dells 2724 (L2 switch).
My problem is that I am not able to get Ip address from the DHCP server on 10.1.5.7 (behind the dell 10.1.5.1)
I can manually config ip address on the pc behind all the dells and can ping all devices.
Also I cannot release the IP address. even after I set the PC to dynamic IP address allocation, it will always get the old static Ip address.
The network diagram is as follows:
router (10.1.1.1)
|
|
|(10.1.1.2)
3560
|
|
|---------------------------|-----------------------------|
| | |
dell 2724 dell 2724 dell 2724
(Vlan5) (Vlan 6) (Vlan 7)
(dell's IP 10.1.5.2) (dell's IP 10.1.6.2) (Dells IP=10.1.7.2)
(DHCP on 10.1.5.7)
config of the cisco switch is as follows:
cisco_switch_b>
cisco_switch_b>en
Password:
cisco_switch_b#sh
cisco_switch_b#show run
cisco_switch_b#show running-config
Building configuration...
Current configuration : 2354 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cisco_switch_b
!
enable secret xxx
enable password xxx
!
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface GigabitEthernet0/1
description To Internet Router
no switchport
ip address 10.1.1.2 255.255.255.0
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet0/8
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet0/9
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet0/10
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet0/11
switchport access vlan 6
switchport mode access
!
interface GigabitEthernet0/12
switchport access vlan 6
switchport mode access
!
interface GigabitEthernet0/13
switchport access vlan 6
switchport mode access
!
interface GigabitEthernet0/14
switchport access vlan 6
switchport mode access
!
interface GigabitEthernet0/15
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet0/16
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet0/17
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet0/18
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
ip address 10.1.5.1 255.255.255.0
!
interface Vlan6
ip address 10.1.6.1 255.255.255.0
ip helper-address 10.1.5.7
!
interface Vlan7
ip address 10.1.7.1 255.255.255.0
ip helper-address 10.1.5.7
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line vty 0 4
password xx
no login
line vty 5 15
password xxx
no login
!
end
cisco_switch_b#
07-05-2005 10:01 PM
Hello,
several reasons could be causing your problem: first of all, it is always advisable to configure the access ports (GigabitEthernet0/7 through 0/18 in your case) with the ´spanning-tree portfast´ command, in order to avoid DHCP broadcast timeouts in connection with the port moving through the various STP states.
Also, you might want to try and configure the global command ´ip forward-protocol udp´ on your switch.
Check the document below for troubleshooting information regarding to UDP broadcasts:
Understanding and Troubleshooting DHCP in Catalyst Switch or Enterprise Networks
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a00800f0804.shtml
HTH,
GP
07-07-2005 12:10 PM
thanks for the URL for trouble shooting tips. The problem was found int he DHCP itself holding on to old IP Addresses.
Now that I got pass that, I need to verify if the VLAN trunk to the Dell works or not. What is the best way of doing that?
07-06-2005 09:42 AM
I am a little puzzled by your description of the problem. Especially where you say that if you configure the PC for dynamic addressing it will get the same static address. It is a normal behavior in DHCP for an end station to attempt to get the address that it had last time.
The configuration of helper address looks ok to me. I would suggest doing something to demonstrate whether you are communicating with the DHCP server or not.
To investigate the problem please post the output of the following:
- do ipconfig and post the output (to demonstrate the current address)
- do ipconfig /release
- do ipconfig and post the output (to demonstrate whether the address was released)
- do ipconfig /renew
- do ipconfig and post the output (to demonstrate whether an address has been learned)
HtH
Rick
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide