cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
764
Views
0
Helpful
3
Replies

QoS issue

agustinmar
Level 1
Level 1

Hi:

 

I have a strange problem with QoS. I have a QoS configuration in a Hub-and-spoke topology. When traffic begins to expand the VoIP calls are broken. But the strange thing is that bandwidth does not reach the bandwidth limit, and neither of the two classes collapses at any time, and for this reason when I see the show policy-map interface statistics I don’t see drop packets. It is very strange.

 

These are configurations:

 

HUB device

=========

 

class-map match-any REALTIME_QOS

match dscp ef

!

class-map match-any REALTIME_MARK

match access-group name REALTIME_ACL

match protocol h323

match protocol rtp

match protocol rtcp

!

# 10.10.10.0 255.255.254.0 is the VoIP Call Manager network in the Data Center

# Hub device is in the Data Center

ip access-list extended REALTIME_ACL

permit ip 10.10.10.0 0.0.1.255 any

!

policy-map QoS_300M

class REALTIME_QOS

  priority

  police 110000000 conform-action transmit  exceed-action drop

class class-default

  bandwidth remaining percent 100

  random-detect dscp-based

!

policy-map SHAPPING_300M

class class-default

  shape average 300000000   

   service-policy QoS_300M

!

policy-map DSCP_MARK

class REALTIME_MARK

  set dscp ef

class class-default

  set dscp af31

!

interface Tunnel25

description GRE tunnel

ip address x.x.x.x x.x.x.x

< Omitted Commands >

ip tcp adjust-mss 1356

qos pre-classify

tunnel source GigabitEthernet0/0/1

tunnel destination x'.x'.x'.x'

!

interface GigabitEthernet0/0/0

description LAN Interface

ip address y.y.y.y y.y.y.y

< Omitted Commands >

service-policy input DSCP_MARK

!

interface GigabitEthernet0/0/1

description WAN Interface

ip address z.z.z.z z.z.z.z

< Omitted Commands >

service-policy output SHAPPING_600M

 

 

SPOKE device

===========

 

class-map match-any REALTIME_QOS

match dscp ef

!

class-map match-any REALTIME_MARK

match access-group name REALTIME_ACL

match protocol h323

match protocol rtp

match protocol rtcp

!

# 10.10.10.0 255.255.254.0 is the VoIP Call Manager network in the Data Center

# Spoke is in a remote site

ip access-list extended REALTIME_ACL

permit ip any 10.10.10.0 0.0.1.255

!

policy-map QoS_100M

class REALTIME_QOS

  priority

  police 20000000 conform-action transmit  exceed-action drop

class class-default

  bandwidth remaining percent 100

  random-detect dscp-based

!

policy-map SHAPPING_100M

class class-default

  shape average 100000000

   service-policy QoS_100M

!

policy-map DSCP_MARK

class REALTIME_MARK

  set dscp ef

class class-default

  set dscp af31

!

interface Tunnel25

ip address x'.x'.x'.x' x'.x'.x'.x'

< Omitted Commands >

ip tcp adjust-mss 1356

qos pre-classify

tunnel source GigabitEthernet0/0

tunnel destination x.x.x.x

!

!

interface GigabitEthernet0/0

description WAN Interface

ip address y.y.y.y y.y.y.y

< Omitted Commands >

!

interface GigabitEthernet0/1

< Omitted Commands >

!

interface GigabitEthernet0/1.50

description LAN Subinterface

encapsulation dot1Q 50

ip address z.z.z.z z.z.z.z

<Omitted commands>

service-policy input DSCP_MARK

 

Could you help me?

 

Thank you.

 

Best regards

3 Replies 3

chrihussey
VIP Alumni
VIP Alumni

Hello, 

Take a closer look at your HUB. You created "policy-map QoS_300M" but have "policy-map QoS_600M" configured on the WAN interface.

Regards

Joseph W. Doherty
Hall of Fame
Hall of Fame
Could you further describe your WAN topology?

Duplicate post  

https://community.cisco.com/t5/routing/qos-issue/m-p/3922677#M321364

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: