03-08-2005 01:20 AM - edited 03-02-2019 10:02 PM
Hi, as a noob im running into difficuly setting my 2600 router up for traffic shapping. I have a router with the following config
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
memory-size iomem 20
frame-relay switching
!
!
!
!
interface BRI0/0
no ip address
shutdown
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface Ethernet1/0
description NAT Ethernet 2600 Router
ip address 192.168.87.3 255.255.0.0
ip nat inside
priority-group 1
!
ip default-gateway 192.168.7.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.7.1
!
!
ip access-list standard exit
access-list 101 permit udp any any
access-list 102 permit tcp any any
priority-list 1 protocol ip low list 101
priority-list 1 protocol ip high list 102
priority-list 1 default low
!
!
line con 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end
Nice and simple. For accessing the web, games etc it works perfectly. The problem I have is I want to traffic shape certain packet types namely UDP so they have priority over TCP.
Basically I want to be able to download files while allowing games to be played over the Internet with as small increase in latency as possible.
I have a 1mbit ADSL line. Running the DEBUG priority-list does show that the above config is giving the right priority It just makes no difference when testing.
Any ideas,
Many thanks for you help
Andy
03-08-2005 01:59 AM
I think the point here is that you can manage the prioities of your outgoing traffic, but that would not have any influence over the incoming traffic. For packets in that direction, it depends on the priorities determined by your service provider's router.
At that point, I should hand over to someone who knows more about QoS. I believe it is possible to influence the incoming traffic using WRED, but only for TCP traffic. It is done by deliberately dropping packets occasionally, which forces the TCP to re-transmit, and so slows it down. But I haven't studied that chapter in sufficient detail yet.
Kevin Dorrell
Luxembourg
03-08-2005 11:51 PM
Does no one know? There is a link to a linux version using QoS called the wondershaper wonder if this helps http://lartc.org/wondershaper/
Many thanks again
Andy
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide