cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
638
Views
4
Helpful
2
Replies

Vlan definition

admin_2
Level 3
Level 3

Hi,

I'm a newbie guy in this area, hoping that somebody could give a hand here. The problem : I'm trying to include a vlan definition on a 2924-XL switch. I'm not an expert on this field,but I like to know how can I include a vlan definition for a port located in this switch.

I know basic things about this matters: how to access the switch via telnet, how to display the configuration, how to show the interfaces, how to enable the configuration mode and so on... the problem here is that I'm not familiar modifying configurations.

Here is the configuration for the switch that I want to modify...

Using 1233 out of 32768 bytes

!

version 11.2

no service pad

no service udp-small-servers

no service tcp-small-servers

!

hostname SWITCH5

!

enable secret xxxxx

!

!

ip subnet-zero

!

interface VLAN1

ip address 172.19.96.109 255.255.255.192

no ip route-cache

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

switchport mode trunk

!

interface FastEthernet0/20

switchport access vlan 40

!

interface FastEthernet0/21

!

interface FastEthernet0/22

switchport mode trunk

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

ip default-gateway 172.19.96.65

snmp-server xxxx

snmp-server xxxxx

snmp-server chassis-id 0x0F

!

line con 0

exec-timeout 0 0

stopbits 1

line vty 0 4

password PASSWRD

login

!

end

I just want to know (step by step if it is possible), how can I include vlan 10 as a VLAN definition for interface FastEthernet 0/18. Vlan 10 has been previously defined on our network (like vlan 40 - used in port 20), so the change should work without issues for port 18.

Maybe this is a silly problem, but I can't find the communication support guy at the moment and I'm in a hurry !

Thanks,

FC

2 Replies 2

yar9960
Level 1
Level 1

This CCO site goes over the basics of creating and manipulating VLAN information on this platform switch. As is outlined in the doc, you'll need to use the "vlan database" command from privileged mode to add, delete, or modify vlans.

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a008009478e.shtml#confthevlancat

Once you've created the VLAN, you can assign specifics ports to the correct VLAN via interface config mode.

Good luck!

anar
Level 1
Level 1

You can also, directly specify whic vlan does this interface belngs to.

int f0/18

switchport mode access

switchport access vlan 10

end

your vlan 10 will be created without any other manipulations.

sh vlan