I have a 7204 with an ATM circuit carrying PVCs for our DSL subscribers. I have authentication working and the connectivity is good. However, I want to NAT the subcriber traffic coming into the router on the ATM circuit to a global IP on the Ethernet inferface. For some reason it will not translate traffic coming in over the subinterfaces of the ATM circuit. Help would be appreciated. My config looks something like this:
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
aaa new-model
aaa authentication login default local
aaa authentication ppp default group radius
aaa accounting network default start-stop group radius
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
interface FastEthernet1/0
ip address 192.168.1.17 255.255.255.192
ip nat outside
interface ATM2/0
no ip address
atm scrambling cell-payload
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
no atm ilmi-enable
interface ATM2/0.32 point-to-point
ip unnumbered Loopback0
ip nat inside
class-int test
atm route-bridged ip
pvc 1/32
encapsulation aal5snap
protocol ppp Virtual-Template1
protocol pppoe
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool dsl
ppp authentication pap chap
ip local pool dsl 10.1.1.5 10.1.1.6
ip nat pool test 192.168.1.5 192.168.1.6 netmask 255.255.255.192
ip nat inside source list 1 pool test
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
access-list 1 permit 10.1.1.0 0.0.0.255
radius-server host 10.1.1.3 auth-port 1645 acct-port 1646
radius-server retransmit 3