Showing results for 
Search instead for 
Did you mean: 

Problem with SCA BB and Cisco CM

Level 1
Level 1

Hello everyone,

I am having a little problem with SCA BB and Cisco CM.

First of all, let me get you familiar with the final goal I'm trying to achieve here - I need to

implement somewhat monitoring of the total bandwidth, consumed by certain services or applications.

Records of the required services (that need to be monitored) are created in SCA BB using Service

Configurator Editor.

To do this I...

1) created a service signature using the Signature Editor

2) connected the dss file to the Service Configurator Editor

3) filled in the column with required ip protocol and port numbers in Protocol settings

4) created a zone, filling a Zone Item with IP address of my server

5) created a new service in Classification Tree and added Service Element, filling the field with

custom protocol and zone

6) pressed 'Apply Service Configuration to SCE' and waited for the end of the process and then another

30 minutes after that

And here comes the sad part

7) tried to create a report for selected service by right clicking on service-> report-> Global

Bandwidth per Service,

I set the time in graph properties and pressed ok. After that, the following error was displayed

but reports of default services like 'Browsing/HTTP' or 'Net Admin/Terminals' work fine.

I tried all this on three different software configurations – no luck whatsoever.

Configurations were:

WindowsXP SP3

SCE2020+scos-v3.6.0 + SCA BB 3.6.0 + CM 3.6.0 + mqsql

SCE2020+scos-v3.7.0 + SCA BB 3.7.0 + CM 3.7.0 + mqsql

SCE2020+scos-v3.7.5 + SCA BB 3.7.5 + CM 3.7.5 + mqsql

What am I doing wrong? Am I missing something?

any help or advice is truly appreciated.

Thanks in advance!

5 Replies 5

Cisco Employee
Cisco Employee

HI Petr,

Do you have this problem only when you create DSS or it is the same even without this. Could you please test it?

Also if you can share sh version from that SCE.



SCE2000#sh ver

System version: Version 3.7.0 Build 222

Build time: Jun 10 2011, 17:12:22 (Change-list 680641)

Software version is: Version 3.7.0 Build 222

Cryptography class: K9

Hardware information is:

rx            : 0x0079

dp            : 0x1d08

tx            : 0x1712

ff            : 0x0077

cls           : 0x1e05

cpld          : 0x0025

lic           : 0x0202

lic-drv       : 0x02020000

lic-prm       : 0x02020000

rev           : G001

Bootrom       : 2.1.0

L2 cache      : Samsung 0.5

lic type      : 4GBE

optic mode    : SM

Product S/N   : CAT1329G03Z

Product ID    : SCE2020-4XGBE-SM

Version ID    : V04

Deviation     :

Part number       : 800-26600-08

Revision          : C1

Software revision : G001

LineCard S/N      : CAT1337G03Q

Power Supply type : AC

SML Application information is:

Application file: /tffs0/release_.sli

Application name: Engage SML Version 3.7.0 build 26 (Protocol Pack 28 build 13)

Using Lib - PL_V3.7.0PP_B66

Using Lib - Classifier_V3.7.0_B66

Application help: Entry point of Engage

Original source file: /auto/srbu-proj1-bgl/apps/users/aninatar/autoBuild/App/SML/Engage/V3.7.0/src/com/pcube/AppTemplate/Main/template_app_main.san

Compilation date: Wed, March 28, 2012 at 01:56:57

Compiler version: SANc v3.20 Build 14 built on: Tue 08/04/2009 06:58:22.;SME plugin v1.1

Capacity option used: 'EngageDefaultSCE2000'.

Logger status: Enabled

Platform: SCE2000 - 4xGBE

Management agent interface version: SCE Agent 3.7.0 Build 206

Software package file: /tffs0//images/SEOS.pkg

SCE2000  uptime is 10 hours, 38 minutes, 43 seconds

Hi again,

It seems fine. What about DSS specific scenario. If you try to apply only default configuration without any DSS is it the same or not?

Is this specific to DSS you created or not? PLease test it.

For me it looks like SCA BB installation. I would install it again. Have you tried that?

also please check this one and make sure that correct SCE is slected and you do refresh. Also check if your CM was updated after applying the config.

I tried to apply default config without any DSS. I created a new service, set there telnet as protocol and

the same error occurred.

Yes, I was tried to reinstall SCA BB. This does not solve the problem.

I've tried to troubleshooting the mysql. I found that the CM creates only 13 tables in apricot.

I've tried to find service records in DB using serviceID, but there are no records for custom services, unlike default ones.

Hi Petr,

For report you mentioned RPT_LUR table will be queried.

If you check the doc here:

you will see all the fields in the table.

you can check all the services in the table by SELECT DISTINCT GLBL_USG_CNT_ID FROM RPT_LUR;

Check if you have that specific one which when you select it you received the error. If you hover the mouse over service in SCA BB you will see what is a Global Counter.

Also if would be nice to have the following:

Go to SCA BB Window Preferences Configuration and enable Send Debug to...

Try to apply the configuration again, wait util it is finished and confirm that CM you use was updated in Console Window of SCA BB.

Make sure that you select right SCE from template and to refresh it in Reporter like expalined in

Collect also debugs from SCA BB Help About SCA BB Configuration Details View error log.

There we should see more details of what happened.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: