cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5260
Views
10
Helpful
3
Replies

VSOM and Windows 10... Has anyone been able to get it to work?

Scott Donahue
Beginner
Beginner

VSOM works fine on all of our Windows 7 computers but cannot get it to work on Windows 10.

Before you ask, yes SASD does work but need to get VSOM to work.  When loading Windows 10 new edge browser everything looks great, even has the gold border around the view window but when you try to view a camera it pops up the following error.

"RTSP video is not supported without VLC web pluggin."

I have even tried installing VLC and still no luck.

When opening VSOM in Windows 10 IE 11, it's like a normal first time load where it wants to install the client but it tries to load the Cisco Multi-Pane Video Surveillance Client 32 bit - 7.6.29 even though the computer is using 64 bit.  Trying to continue the install it fails and just says the installation is not yet complete. Are you sure you want to exit?... Select No and looks like it tries to install but then fails again with the pop up...  "Module C:\Program Files (x86)\Cisco\Cisco Multi-Pane Video Surveillance Client 32 bit\vsmc70Rt.dll failed to register.  HRESULT -2147024714.  Contact your support personnel.  Then if you try to continue several other.dll files fail and ultimately just gives an error: Invalid parameter: MPClientXML pointer is null in createView.

It will be a point were none of our machines are running Windows 7 so will need to find a way to make this work.  Any help would be greatly appreciated.

Thanks,

Scott

3 Replies 3

Scott Olsen
Frequent Contributor
Frequent Contributor

I can definitely appreciate the position you are in.  Luckily, all of our clients have dedicated workstations that are maintained at Windows7 64bit.

I myself haven't had Windows 10 shoved down my throat yet, but when it happens, I'll surely be facing the same situation and I'll report back to this thread if it's still an issue.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

Daniel de Varona
Beginner
Beginner

VSOM on Windows 10 with Firefox and the VLC plugin works, although the video takes about 7-10 seconds to load. I'm using VSM 7.6.1 right now.

Neither IE nor Chrome will show video.

Scott Donahue
Beginner
Beginner

Great news... I got VSOM to work in Windows 10.  Not sure if it was a fluke as I was tweaking every possible setting I could think of but low and behold I got it to work and it's fast and have the 17 view options which is only possible in a 64 bit environment.

Looking back though my settings this is what I have.

Do not use the Windows 10 EDGE browser, it wont' work, instead you have to use the IE 11.

IE 11 internet options under the Security tab I have Enable Protected Mode checked on each of the zones. (Internet, Local intranet, Trusted sites, Restricted sites)

Under the Advanced tab in the Security section I have checked... Enable 64-bit processes for Enhanced Protected Mode but surprisingly NOT checked is Enable Enhanced Protected Mode which from everthing I read said it had to be.  To verify if this makes a difference I checked to Enable it and it does affect the ability to view the cameras.  It will display a warning, "This webpage wants to run 'Cisco Javascript Bridge Class' which isn't compatible with Internet Explorer's enhanced security features.  If you trust this site, you can disable Enhanced Protected Mode for this site and allow the control to run.   If you (Click on Run Control) it will revert the browser back to a 32-bit tab and just have a while window saying Invalid parameter: MPClientXML pointer is null in updateSource.  Go back into Internet Options and UNCHECK Enable Enhanced Protected Mode.  I did verify that after making that change, I am able to successful view the cameras. (YEAH!!!)

If you also want to get rid of the Certificate error when loading VSOM, in the Internet Options, on the Advanced tab also uncheck Warn about certificate adress mismatch and then on the address bar while it's red warning about the certicate error.  Then when you open VSOM in the browser, click on the certificate shield and click on view certificates, then install certificate then next, choose place all certificates in the following store, choose browse, then select Trusted Root Certifcation Authorities, then OK and next then Finish.  When the security warning comes up, select Yes to install this certificate and then OK on the import was successful.  Next time you open VSOM you won't have the certicate warning.

After changes are made you MUST reboot your computer for the settings to fully take effect.

Hope this helps...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers