cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
291
Views
2
Helpful
6
Replies

radkit 1.6.8 client login_sso fails

andriio
Level 1
Level 1

hi there
installed new service on the virtual desktop . Service is configured with company proxy & connected.
when trying to login_sso from client just from the same virtual desktop error triggers:
>>> client = sso_login(<myciscocomemail>)
11:52:59.010Z ERROR | could not connect to prod.radkit-cloud.cisco.com:443, retrying in 60 [error='socket.gaierror: [Errno 11001] getaddrinfo failed\n' ssl=_RADKit_SSLContext(tls_minimum_version=TLSv1_3, tls_maximum_version=TLSv1_3, sha256_fingerprint=None, ocsp_proxy_stapler_url=https://prod.radkit-cloud.cisco.com/ocsp/verify, )]
browser window doesnt popup

1 Accepted Solution

Accepted Solutions

Hi @andriio ,

Oh got your point. You can create a toml file using the method in this link for clienthttps://radkit.cisco.com/docs/pages/proxy_support.html#client-service

TOML setting

Under your home directory, create a file called .radkit/client/settings.toml for the Client containing:


[cloud_client.proxy] url="<your own proxy details:port>"

View solution in original post

6 Replies 6

Rana Khalil
Cisco Employee
Cisco Employee

Hello,

Thanks for reaching out.

 

Can you verify the connectivity to the cloud endpoints? 

Radkit only needs https access to two ip addresses.

You can get them by executing the Linux command

curl https://prod.radkit-cloud.cisco.com/endpoints

(Or simply browse to the URL)

You will obtain a JSON file containing the ip addresses and ports radkit needs to reach

The user will also need to access cisco.com over https and be able to log in to Cisco with their CCO credentials

 

How was the proxy configured? Configuration steps can be found at: https://radkit.cisco.com/docs/pages/proxy_support.html#client-service.

Waiting for your kind feedback.

Regards,

Rana

Hi
with proxy i have no problem to connect to prod.radkit-cloud.cisco.com 443
Service configured with proxy & connected

andriio_1-1712927328032.png

for me it looks like client doesnt use configured proxy

 

Hi @andriio ,

Oh got your point. You can create a toml file using the method in this link for clienthttps://radkit.cisco.com/docs/pages/proxy_support.html#client-service

TOML setting

Under your home directory, create a file called .radkit/client/settings.toml for the Client containing:


[cloud_client.proxy] url="<your own proxy details:port>"

tons of 10x. it worked

@andriio 

You are most welcome! Happy to help!

Rana Khalil
Cisco Employee
Cisco Employee

If you have followed the above method already and still no luck.

Please reach out to me to schedule a meeting: rankhali@cisco.com