cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Who Me Too'd this topic

Static route with same target network but different next hops

Blvesteel
Level 1
Level 1

Good day,

I am trying to use Static route for 2 separate network with the same subnet (see attached image). However when i applied the config(see below), the ping from pc to the center router is inconsistent. I know the router is confused and tries to deliver the traffic to both the next hops indicated. How can i have 100 percent ping with just

 

-static route

-def route going to center router

-not changing the LAN IP

 

And just in case, does the solution involves the right type of static-recursive, direct, fully specified?

 

The config is below,

//////////////////////////////R2/////////////////////////////

!
interface FastEthernet0/0
description Gateway of LAN
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
description Link to R1(center router)
ip address 192.168.1.2 255.255.255.0
!
interface Serial3/0
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip flow-export version 9

////////////////////////////////R1/////////////////////////

interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
description link to R2(left router)
ip address 192.168.1.1 255.255.255.0
clock rate 2000000
!
interface Serial3/0
description link to R3(right router)
ip address 192.168.2.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 10.1.1.0 255.255.255.0 192.168.1.2
ip route 10.1.1.0 255.255.255.0 192.168.2.2
!
ip flow-export version 9
!

//////////////////////////////////R3/////////////////////////////////////////

!
interface FastEthernet0/0
description gateway of LAN
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
shutdown
!
interface Serial3/0
description Link to R1(center router)
ip address 192.168.2.2 255.255.255.0
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
ip flow-export version 9
!

 

 

 

Thank you in advanced

Who Me Too'd this topic