cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2497
Views
10
Helpful
8
Replies

RV320 Can't generate OpenVPN server and client certificates

RobertDH
Level 1
Level 1

Hi all,

I'm trying to setup an openVPN server on a rV320 router. but the Certificate generator doesn't seem to work.

I can generate a self signed certificate without a problem but when i try to enable the openVPN server I cant select it in the "Root Certificate Authority" box.

I've also tried to create the certificates using the certificate generator. I am alble to select the my self signed certificate in the Root Certificate Authority box, after I click safe the interface jumps to the OpenVPN Certificate tab but no certificates are there....

No error is thrown, I'm on the latest firmware, I have tried restarting.

The strange thing is I was able to create those certificates earlyer today.

It's like the OpenVPN service doesn't accept certificates or something like that.

 

Please help!

 

Cheers,

Robert.

8 Replies 8

balaji.bandi
Hall of Fame
Hall of Fame

there is a good thread for reference, please refer and let us know how it goes? (one of the posts has a document which has good steps).

 

https://208.74.205.244/t5/small-business-routers/how-to-configure-cisco-rv320-openvpn-internal-server/td-p/2901000/page/2

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi Balaji, thanks for helping!
I can only find the document on how to setup OpenVPN server, but I know how to do it and I did it succesfully before but now suddenly the cetificates aren's generated. I don't get an error, the OpenVPN certificate list stays empty.

 

Or are you referring to another document?

I have the same problem here. Cisco RV320 and no possibility to create OpenVPN certificate. Do you have some solution for this?

 


JiriKoch, I have observed that the problem started to occur when I deleted future dated self-signed certificates. Then this problem started that I can't generate certificates for OpenVPN.
greetings!

dpaseguridad
Level 1
Level 1

Hi RobertDH, I have the same problem. Have you been able to solve it? If it is correct, please could you share the solution? Thank you very much.

gheatly
Level 1
Level 1
Same here. No OpenVPN certificates generating on RV320, updated to the latest firmware. Anyone having any luck??

Not sure if this would help anyone in this situation and perhaps would be of more help to tech support but after recreating all of my certificates for a different issue, that led to no longer being able to create OpenVPN certificates as noted in my prior posts, I managed to keep an earlier OpenVPN config file used for this connection with previous encrypted certificate information in it (sorry for the run-on sentence). Now, with no OpenVPN certificate entries on the RV320 (because I cannot visibly create those certificates) but with the master self-signed certificate and self-signed trusted ipsec certificate, I am still able to make the VPN connection using the OpenVPN client. Go figure!!

FYI, when I export the OpenVPN config file from the RV320, the ca section is empty. I was hoping the no OpenVPN certificates issue was more of an interface issue than anything else but it makes sense that if I am unable to create certificates, the RV320 would not save anything to its database. Right now, I do not have the option to restart the RV320 or factory default it to see if that fixes everything.

tmaier64
Level 1
Level 1

Does anyone have a solution for this problem, 'cause I can't get it working at all.

I had the same problem, a certificate that begins  2082, that came with firmware I suppose.

With that I was able to create all OpenVPN certificates but connection didn't work because of the root ca that begins far in the future.

So, I created my own root ca, but now I can't create any other OpenVPN certificates, Rv325 just ignores that, and nothing is logged.

Is there any solution or do I something wrong.