cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1673
Views
0
Helpful
2
Replies

RV340 IPv6 6RD configuration

dklane012
Level 1
Level 1

Hello all,

Hoping someone can confirm whether or not the RV340 can setup a 6RD tunnel correctly.

I have the unit connecting to CenturyLink - symmetric gigabit fiber service.

The router is plugged into the ONT, WAN1 is configured for VLAN tagging - 201 - and have the PPPoE login setup and working.

So, IPv4 service is working, speedtests of connected gear is getting up to 900+MBps up and down and network services are working.

When I go to setup IPv6, I am just selecting the ipv6 transition option, 6RD - leveraging the Centurylink information:

I only get to choose between WAN 1 or WAN 2 - WAN1.201 is not available, but the public facing IP address shows up on WAN1 on this screen - I have a static address assigned and it shows correctly.

Then in the other options:

6rd

IPv4 Address Relay is 205.171.2.64, IPv4 Common Prefix Length - 0

IPv6 Prefix/Length - 2602::  / 24

I have the WAN1.201 interface added into the Multi-WAN Table as 1 and WAN1 as 2 - both at 100% - should I change that to make this work?

I also have the Router Advertisement on the LAN side working correctly - clients are getting addresses in the right subnet - but in Win10, the clients show 'deprecated' in ipconfig.

 

In the instructions for the RV2XX series, there is mention of turning off IPv6 on the WAN1.201 and WAN1 interface - which makes sense - to get 6rd working, but 1.0.1.17 update on the RV340 does not show the option of turning off IPv6 - is this just a bug and I need to wait for the fix?

 

Hopefully someone knows - this the last thing I need working - otherwise it is supporting 40+ devices and working well so far.

2 Replies 2

dklane012
Level 1
Level 1

Just an update here.

 

I never could get this to work and this did not work well for UPnP, either.  This is running in a home with multiple Xboxes - so needed to get Open NAT working on multiple devices.

I had purchased an Edgerouter Lite about a year and a half ago and let it sit - it had some problems then with a couple of things, but apparently their firmware has been updated to address everything in my scenario.

 

So, I now have gigabit speed, PPPoE, IPv6, UPnP working correctly, a little light web filtering for malware and 40 - 50 devices all connecting well. 

And cost would have been about 1/3 of the RV340.   If this would have 'just worked' it would have been worth the $$, but with the hassle and the ease of setup of the Edgerouter, its no contest.

And zero 'official' help, so much for Cisco having 'more support'.

Can a Cisco employee or forum lead please take a look at this?

I've tried about six different ways (6rd and manual both), and I'm not having much luck here.

No one would call me a network admin, but I'm reasonably schooled on the network stack basics, most command-line tools, and how to do basic and some intermediate style routing.


I keep having a TON of issues, every time I enable Router Advertisement on my 2nd (Dual WAN, one ISP has native IPV6, second uses an auto-config tunnel) IP range.
My machines get the IPs fine, but I can't actually get it to pass any packets, except over my LAN.

I've also tried with only the tunnel-based ISP, same deal, except that (obviously) all my IPV6 routing is blocked, outside my LAN (inside my LAN is great, all my machines and devices work on either VLAN).

 

Edit: Do any employees "monitor" threads here, and "move things along", if they're stuck?  Trying to get somewhere here, to no end.

I have managed to get "either" my native OR tunneled solution working, sort of.  

As soon as I try to add the 2nd router-advertisement for the second IPV6, things fall apart, fast.  IPV6 (WAN anyway, LAN routing still works) stops working, and no amount of reboots, or even a reset and re-image from file works.

The ONLY thing I've found that fixes this at this point is a full-factory-reset, and then a manual configuration (big pain, because I have a bunch of fixed devices in my LAN, no way to import them in the UI).


I'm really frustrated with the (lack of) support here, it seems like the employees were doing some work on issues here, if they got "stuck", but not so much now, I've posted to several threads (no reason to re-create a new thread, same issue, right?), and have had zero response.  Not faulting the community here, necessarily, but more Cisco, for not doing anything (I'm tempted to try posting some indecent words, just to see if a moderator will intervene, but will refrain from that "test" for now...).