cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2058
Views
0
Helpful
7
Replies
Beginner

1841 Static IP Configuration

Hello,

 

I have issue after configuring the static IP here's the IP subnet from ISP

IPs: 51.39.10.42 - 51.39.10.46

Netmask : 255.255.255.248

Gateway : 51.39.10.41

 

and here's my router configuration

 

 

Building configuration...

Current configuration : 1419 bytes
!
! Last configuration change at 01:43:51 UTC Tue Feb 13 2018
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
!         
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO1841 sn FTX115220A2
!
redundancy
!
!
controller Cellular 0/0
!
controller Cellular 0/1
!
! 
!         
!
!
!
!
!
interface FastEthernet0/0
 ip address 51.39.10.44 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 51.39.10.41
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 10 interface FastEthernet0/0 overload
ip default-network 51.39.10.41
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
logging esm config
access-list 10 permit any
!
!         
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 0/0/0 0/0/1
 no exec
line 0/1/0 0/1/1
 no exec
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end

i can't ping outside to 8.8.8.8, but when i gave the IP to any PC connected to the ISP router it's working without any issues also i can ping to gateway from 1841 Router

 

 

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Guru

Re: 1841 Static IP Configuration

"no access-list 10"
"access-list 10 permit 192.168.2.0 0.0.0.255"

 

"no ip default-gateway 50.39.10.41" 

"no ip route 0.0.0.0 0.0.0.0 fa0/0"

 

"ip route 0.0.0.0 0.0.0.0 50.39.10.41" 

 

Jon

View solution in original post

7 REPLIES 7
VIP Advisor

Re: 1841 Static IP Configuration

Hi

At simple sight there are 2 problems: 

1) The NAT settings are not completed, so you must add: 

 

Interface fa0/0

description TO-ISP

ip nat outside

 

interface fa0/1

description TO-MY-NETWORK

ip nat inside 

 

2) You need to define your private network, for testing you could set up a loopback:

 

interface loopback 0

ip add 1.1.1.1 255.255.255.255

ip nat inside

 

then test:

 

ping 8.8.8.8 source loopback 0

 

It should work. 

 

This command is not required, so you can remove it.

ip default-network 51.39.10.41

 

Hope it is useful

:-)

 

 

Beginner

Re: 1841 Static IP Configuration

Dear, I have tested it but no chance to get it working

 

Building configuration...

Current configuration : 1582 bytes
!
! Last configuration change at 06:11:36 UTC Tue Feb 13 2018
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
!         
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO1841 sn FTX115220A2
!
redundancy
!
!
controller Cellular 0/0
!
controller Cellular 0/1
!
! 
!         
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/0
 ip address 50.39.10.44 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Cellular0/0/0
 no ip address
 encapsulation ppp
!
interface Cellular0/1/0
 no ip address
 encapsulation ppp
!
interface Cellular0/0/1
 no ip address
 encapsulation ppp
!
interface Cellular0/1/1
 no ip address
 encapsulation ppp
!
ip default-gateway 50.39.10.41
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!         
ip nat inside source list 10 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
logging esm config
access-list 10 permit any
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 0/0/0 0/0/1
 no exec
line 0/1/0 0/1/1
 no exec
line vty 0 4
 login    
 transport input all
!
scheduler allocate 20000 1000
end
Hall of Fame Guru

Re: 1841 Static IP Configuration

"no access-list 10"
"access-list 10 permit 192.168.2.0 0.0.0.255"

 

"no ip default-gateway 50.39.10.41" 

"no ip route 0.0.0.0 0.0.0.0 fa0/0"

 

"ip route 0.0.0.0 0.0.0.0 50.39.10.41" 

 

Jon

View solution in original post

Beginner

Re: 1841 Static IP Configuration

Thanks your help it's working
VIP Advisor

Re: 1841 Static IP Configuration

Hi

Have you tried to ping the ISP device? if you got a response the configuration should work. Otherwise is something wrong between your router and the ISP router.

 

ping 50.39.10.X source fastethernet 0/0  ; where 50.39.10.X is the gateway or IP configured on the ISP device. 

 

Beginner

Re: 1841 Static IP Configuration

Hi,

 

why is 

ip address 50.39.10.44 255.255.255.248

I think it should be :

 

ip address 51.39.10.44 255.255.255.248

 

Hall of Fame Master

Re: 1841 Static IP Configuration

Good catch. Clearly the original post did indicate that the ISP had provided subnet 51.39.10.40. If it still does not work after correcting the addressing then please post the output of show ip interface brief and of show arp.

 

HTH

 

Rick

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards