cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
585
Views
0
Helpful
11
Replies

2 links for redundancy

Hi,

in my lab i have this topology :

ca.jpg

between R1 and R4 there are two links.

i want to know how can i use Ipsla  on router R1 to track 199.99.9.9 and  to have only one  operational link , and when it's down ,the second one replace it automatically.

regards

2 Accepted Solutions

Accepted Solutions

Bilal Nawaz
VIP Alumni
VIP Alumni

Hello - you can do this:

R1:

ip sla monitor 99

type echo protocol ipIcmpEcho 199.99.9.9

frequency 10

ip sla monitor schedule 99 life forever start-time now

track 1 rtr 99 reachability

delay down 10 up 1

ip route 199.99.9.9 255.255.255.255 fa0/0 track 1

ip route 199.99.9.9 255.255.255.255 fa1/0 100

This has a floating static route "ip route 199.99.9.9 255.255.255.255 fa1/0 100" this has a metric of 100 and will only be used if the primary route goes down.

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

Oh! i understand, Yes you will need ipsla for R4 as well on any subnet that R1 has or knows how to get to.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

11 Replies 11

Bilal Nawaz
VIP Alumni
VIP Alumni

Hello - you can do this:

R1:

ip sla monitor 99

type echo protocol ipIcmpEcho 199.99.9.9

frequency 10

ip sla monitor schedule 99 life forever start-time now

track 1 rtr 99 reachability

delay down 10 up 1

ip route 199.99.9.9 255.255.255.255 fa0/0 track 1

ip route 199.99.9.9 255.255.255.255 fa1/0 100

This has a floating static route "ip route 199.99.9.9 255.255.255.255 fa1/0 100" this has a metric of 100 and will only be used if the primary route goes down.

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

ok i'm trying this thank you for the reply

it works just one question if i want to do it this time not to track 199.99.9.9 but all destinations it is enough to replace :

ip route 199.99.9.9 255.255.255.255 fa0/0 track 1

ip route 199.99.9.9 255.255.255.255 fa1/0 100

by

ip route 0.0.0.0 0.0.0.0 fa0/0 track 1

ip route 0.0.0.0 0.0.0.0 fa1/0 100


Yes, this will be for all routes that your router does not know about. i.e. anything that is not in the routing table, it will be using the default route.

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

i do what you say first time it works , i entered the command ping 199.99.9.9 repeat 1000 and i delete the  first link :

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!......................!!!!!!!!!

etc

but whene i replace

ip route 199.99.9.9 255.255.255.255 fa0/0 track 1

ip route 199.99.9.9 255.255.255.255 fa1/0 100

by

ip route 0.0.0.0 0.0.0.0 fa0/0 track 1

ip route 0.0.0.0 0.0.0.0 fa1/0 100

i have this

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.......

......................................................................

...................

until  the primary become active then it pings :

............!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

what i'm trying to have is not an ipsla for just 199.99.9.9 but for all destination : i want the primary links as default route,and when it is down the secondary become active and this not just for 199.99.9.9

should i define an ip sla for all destinations ?

may be it is possible without ip sla just by defining two routes with different administrative distance,is it possible with ipsla?

thank you


Hello, I have created the same setup as you, with R1 and R4. I have added the 'source-interface' key word in the tracking SLA.

Here is my config on R1:

ip sla monitor 99

type echo protocol ipIcmpEcho 199.99.9.9 source-interface FastEthernet0/0

frequency 5

ip sla monitor schedule 99 life forever start-time now

!

!

track 1 rtr 99 reachability

delay down 5 up 1

!

!

!

interface FastEthernet0/0

ip address 150.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 150.0.1.1 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 track 1

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 100

Here is my config on R4

!

interface Loopback0

ip address 199.99.9.9 255.255.255.0

!

interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 150.0.0.4 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 150.0.1.4 255.255.255.0

duplex auto

speed auto

On R1 I will do a continuous ping and shut down interface fa0/0 on R2... I will ping 1.1.1.1

R1#ping 1.1.1.1 repeat 1000

Type escape sequence to abort.

Sending 1000, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!........!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

*Mar  1 00:20:03.659: %TRACKING-5-STATE: 1 rtr 99 reachability Up->Down!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.

Success rate is 98 percent (726/735), round-trip min/avg/max = 12/20/40 ms

R1#

So it does work, and works pretty fast!

So please give this a go and let me know the results.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

with using

type echo protocol ipIcmpEcho 150.0.0.4

it works,so i should track 150.0.0.4

thank you for help it was useful .

In my opinion you should use this command instead of tracking the interface IP on the other side like this:

type echo protocol ipIcmpEcho 199.99.9.9 source-interface FastEthernet0/0

The loopback is the most reliable interface on the router and therefor you should track the loopback but from a particular interface. In our case fa0/0.

Hope this helps

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

thank you,yes you are right,but  if i ping from router R2 to router R1 (see the primary topology) which link will be used to reach the destination ?

ping 172.16.1.1  (the loopback of R1)

should i define an other ipsla on router R4 ?

I cant' use a default route this time because it is reserved to the loopback 199.99.9.9 (internet)

In your case if you ping from router R2 to a  loopback interface in router R1 which link will be used(your topology).

the icmpecho may go through the  secondary links but when it hit router R1 it will return through the primary link .i don't want that router R2 use the secondary link

Oh! i understand, Yes you will need ipsla for R4 as well on any subnet that R1 has or knows how to get to.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Ok thanks ;-)

Review Cisco Networking for a $25 gift card