cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4218
Views
0
Helpful
10
Replies

4G LTE Config on IR1101

iso00
Level 1
Level 1

I am working with IR1101 running ir1101-universalk9.17.06.01.SPA.bin with P-LTEAP18-GL LTE module.  I am trying to bring the Cell interface up and have been running into some issues. 

 

Relevant configuration here

 

controller Cellular 0/1/0
lte sim data-profile 7 attach-profile 7 slot 0
no lte firmware auto-sim

 

interface Cellular0/1/0
ip address negotiated
load-interval 30
dialer in-band
dialer idle-timeout 30
dialer watch-group 1
pulse-time 1
ip virtual-reassembly
!
interface Cellular0/1/1
no ip address
shutdown

 

ip route 0.0.0.0 0.0.0.0 Cellular0/1/0

 

ip access-list standard 1
10 permit any
dialer watch-list 1 ip 5.6.7.8 255.255.255.255
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
dialer-list 1 protocol ipv6 permit
dialer-list 1 protocol ip permit

 

 

router#sh cellular 0/1/0 radio
Radio power mode = Online
Channel Number = 0
Current Band = Unknown
Current RSSI(RSCP) = -59 dBm
Current ECIO = -65528 dBm
Primary Scrambling Code = 285
Radio Access Technology(RAT) Preference = AUTO
Radio Access Technology(RAT) Selected = UMTS
Network Change Event = unknown

 

router#sh cellular 0/1/0 profile 7
Profile password Encryption level = 7


Profile 7 = INACTIVE* **
--------
PDP Type = IPv4v6
Access Point Name (APN) = TEST
Authentication = None

* - Default profile
** - LTE attach profile

 

router#sh cellular 0/1/0 security
Active SIM = 0
SIM switchover attempts = 0
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3

 

router#sh cellular 0/1/0 firmware
Idx Carrier FwVersion PriVersion Status
1 Generic 32.00.114 1023 Inactive
2 Verizon 32.00.124 2020 Active
3 ATT 32.00.143 4021 Inactive

 

 

*Aug 16 11:05:17.225: Ce0/1/0 DDR: Dialer Watch: resetting call in progress
*Aug 16 11:05:17.225: Ce0/1/0 DDR: Dialer Watch: Check reconnection needed
*Aug 16 11:05:17.225: DDR: Dialer Watch: watch-group = 1
*Aug 16 11:05:17.225: DDR: network 5.6.7.8/255.255.255.255 DOWN,
*Aug 16 11:05:17.225: DDR: primary DOWN
*Aug 16 11:05:17.225: DDR: Dialer Watch: Dial Reason: Secondary of group 1 AVAILABLE
*Aug 16 11:05:17.226: DDR: Dialer Watch: watch-group = 1,
*Aug 16 11:05:17.226: DDR: dialing secondary by dialer string lte on Ce0/1/0
*Aug 16 11:05:17.226: DDR: Dialer Watch: Stale dialer watch group 1 found on Ce0/1/0
*Aug 16 11:05:17.226: Ce0/1/0 DDR: Attempting to dial lte
*Aug 16 11:05:17.226: Ce0/1/0 DDR: Unable to dial lte.
*Aug 16 11:05:17.226: Ce0/1/0 DDR: Dialer Watch: resetting call in progress
*Aug 16 11:05:32.225: Ce0/1/0 DDR: re-enable timeout
*Aug 16 11:05:32.225: DDR: Dialer Watch: watch-group = 1
*Aug 16 11:05:32.225: DDR: network 5.6.7.8/255.255.255.255 DOWN,
*Aug 16 11:05:32.225: DDR: primary DOWN
*Aug 16 11:05:32.225: Ce0/1/0 DDR: Dialer Watch: resetting call in progress
*Aug 16 11:05:32.225: Ce0/1/0 DDR: Dialer Watch: Check reconnection needed
*Aug 16 11:05:32.225: DDR: Dialer Watch: watch-group = 1
*Aug 16 11:05:32.225: DDR: network 5.6.7.8/255.255.255.255 DOWN,
*Aug 16 11:05:32.225: DDR: primary DOWN
*Aug 16 11:05:32.225: DDR: Dialer Watch: Dial Reason: Secondary of group 1 AVAILABLE
*Aug 16 11:05:32.225: DDR: Dialer Watch: watch-group = 1,
*Aug 16 11:05:32.225: DDR: dialing secondary by dialer string lte on Ce0/1/0
*Aug 16 11:05:32.225: DDR: Dialer Watch: Stale dialer watch group 1 found on Ce0/1/0
*Aug 16 11:05:32.225: Ce0/1/0 DDR: Attempting to dial lte
*Aug 16 11:05:32.225: Ce0/1/0 DDR: Unable to dial lte.
*Aug 16 11:05:32.225: Ce0/1/0 DDR: Dialer Watch: resetting call in progress

10 Replies 10

Hello,

 

try and add the lines marked in bold:

 

--> chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
controller Cellular 0/1/0
lte sim data-profile 7 attach-profile 7 slot 0
no lte firmware auto-sim
!
interface Cellular0/1/0
ip address negotiated
load-interval 30
dialer in-band
--> dialer string lte
dialer idle-timeout 30
dialer watch-group 1
pulse-time 1
ip virtual-reassembly
!
interface Cellular0/1/1
no ip address
shutdown
!
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0
!
ip access-list standard 1
10 permit any
--> dialer watch-list 1 ip 5.6.7.8 0.0.0.0
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
dialer-list 1 protocol ipv6 permit
dialer-list 1 protocol ip permit

The chat-script lte took, but dialer string lte did not.  I swapped out the 255.255.255.255 with 0.0.0.0 in dialer watch-list 1.  Slightly different output from dialer. 

 

 

router(config)#interface Cellular0/1/0
router(config-if)#dialer ?
callback-secure      Enable callback security
disable-multiencaps  Disable Multi-Encaps for ISDN
down-with-vInterface Bring down Dialer when Virtual interface is down
dtr                  Set DTR dialing for interface
enable-timeout       Set length of time an interface stays down before it is available for dialing
fast-idle            Set idle time before disconnecting line with an unusually high level of contention
hold-queue           Configure output hold queue
idle-timeout         Specify idle timeout before disconnecting line
in-band              Set v.25bis dialing for interface
leased               Leased/Non-Dial link
map                  Define multiple dial-on-demand numbers
mult-map-same-name   Multiple maps same remote name order Specify order of choosing dialstrings
pool-member          Specify dialer pool membership
pppoe-client-vlan-cos set dot1p cos value in pppoe control packets
priority             Specify priority for use in dialer group
redial               Configure redial for this interface
rotary-group         Add to a dialer rotary group
snapshot             Enable snapshot address for dialer profile
vpdn                 Enable vpdn dial
wait-for-carrier-time How long the router will wait for carrier
wait-for-line-protocol Time the router will wait for the line protocol to come up
watch-disable        Time to wait before bringing down watched route link
watch-group          Assign interface to dialer-watch-list
*Aug 16 16:11:22.149: Ce0/1/0 DDR: Dialer Watch: resetting call in progress
*Aug 16 16:11:22.149: Ce0/1/0 DDR: Dialer Watch: Check reconnection needed
*Aug 16 16:11:22.149: DDR: Dialer Watch: watch-group = 1
*Aug 16 16:11:22.149: DDR:        network 5.6.7.8/0.0.0.0 DOWN,
*Aug 16 16:11:22.149: DDR:        primary DOWN
*Aug 16 16:11:22.149: DDR: Dialer Watch: Dial Reason: Secondary of group 1 AVAILABLE
*Aug 16 16:11:22.149: DDR: Dialer Watch: watch-group = 1,
*Aug 16 16:11:22.149: DDR:        dialing secondary by dialer string lte on Ce0/1/0
*Aug 16 16:11:22.149: DDR: Dialer Watch: Stale dialer watch group 1 found on Ce0/1/0
*Aug 16 16:11:22.149: Ce0/1/0 DDR: Dialing ddb is : Ce0/1/0
*Aug 16 16:11:22.149: Ce0/1/0 DDR: Dialer string selection method [SEQUENTIAL],
  Call in progress was [NULL],
  Recent success call[NULL],
  first_entry[lte]
*Aug 16 16:11:22.149: Ce0/1/0 DDR: Number to call[lte]
*Aug 16 16:11:22.150: Ce0/1/0 DDR: Attempting to dial lte
*Aug 16 16:11:22.150: Ce0/1/0 DDR: Unable to dial lte.
*Aug 16 16:11:22.150: Ce0/1/0 DDR: dialer cannot dial
*Aug 16 16:11:22.150: Ce0/1/0 DDR: Dialer Watch: resetting call in progress
*Aug 16 16:11:37.149: Ce0/1/0 DDR: re-enable timeout
*Aug 16 16:11:37.149: DDR: Dialer Watch: watch-group = 1
*Aug 16 16:11:37.149: DDR:        network 5.6.7.8/0.0.0.0 DOWN,
*Aug 16 16:11:37.149: DDR:        primary DOWN
*Aug 16 16:11:37.149: Ce0/1/0 DDR: dialer cannot dial

 

Hello,

 

I wonder if your SIM (cellular) gets a physical connection at all.

 

Try the below config (no dialer watch), with an offload to a dialer interface and a dialer persistent...

 

--> chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
controller Cellular 0/1/0
lte sim data-profile 7 attach-profile 7 slot 0
no lte firmware auto-sim
!
interface Cellular0/1/0
ip address negotiated
load-interval 30
dialer in-band
--> dialer pool-member 1
pulse-time 1
ip virtual-reassembly
--> async mode interactive
--> routing dynamic
!
interface Cellular0/1/1
no ip address
shutdown
!
--> interface Dialer1
--> ip address negotiated
--> encapsulation slip
--> dialer pool 1
--> dialer idle-timeout 0
--> dialer string lte
--> dialer persistent
--> dialer-group 1
!
--> ip route 0.0.0.0 0.0.0.0 Dialer 1
!
dialer-list 1 protocol ip permit

A number of the configuration parameters are not available under Cellular interface

 

router(config)#interface Cellular0/1/0
router(config-if)#no dialer in-band
router(config-if)#dialer pool-member 1
%Configure a "dialer in-band", or "dialer pool" first.
router(config-if)#dialer in-band
router(config-if)#dialer pool-member 1
%Remove Legacy DDR Configuration first
router(config-if)#async ?
% Unrecognized command
router(config-if)#routing ?
% Unrecognized command
router(config-if)#routing

I also saw a note pertaining to chat scripts in the configuration guide

 

The following features are not supported on Cisco 4G LTE Advanced on the IR1101, when compared to
Classic IOS:
• TTY support or Line
• Chat script/dialer string
• DM log output to USB flash is not supported

Hello,

 

you don't need the async routing or the script. Try and configure only the below, I would like to see if you get a connection on your cell at all:

!
controller Cellular 0/1/0
lte sim data-profile 7 attach-profile 7 slot 0
no lte firmware auto-sim
!
interface Cellular0/1/0
ip address negotiated
load-interval 30
dialer in-band
--> dialer pool-member 1
pulse-time 1
ip virtual-reassembly
!
interface Cellular0/1/1
no ip address
shutdown
!
--> interface Dialer1
--> ip address negotiated
--> encapsulation slip
--> dialer pool 1
--> dialer idle-timeout 0
--> dialer persistent
--> dialer-group 1
!
--> ip route 0.0.0.0 0.0.0.0 Dialer 1
!
dialer-list 1 protocol ip permit

Interface shows up, Profile remains inactive. 

Cellular0/1/0          unassigned      YES NVRAM  up                    up
Cellular0/1/0 is up (spoofing), line protocol is up (spoofing)
  Hardware is LTE Advanced Pro CAT-18 pluggable-Global Multimode LTE/LTE-A/LTE-AP/DC-HSPA+/HS
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 50000 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive not supported
  DTR is pulsed for 1 seconds on reset
  Last input never, output 00:00:20, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     Output 0 broadcasts (0 IP multicasts)
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

Hello,

 

what if you delete the profile ?

 

I am not 100% sure what the command is to create/delete a profile, it could be:

 

cellular 0/1/0 lte profile create 1 APN-name none ipv4v6 <-- to create or modify profiles.


cellular 0/1/0 lte profile delete 1 APN-name none ipv4v6

 

or

 

cellular 0 lte profile delete 1 <-- to delete a profile.

 

no lte sim data-profile 7 attach-profile 7 slot 0

 

and create a new one ?

iso00
Level 1
Level 1

I tried recreating the profile, but did not see any change

 

cellular 0/1/0 lte profile create 8 <apn> none ipv4v6
controller Cellular 0/1/0
no lte sim data-profile 7 attach-profile 7 slot 0
lte sim data-profile 8 attach-profile 8 slot 0

iso00
Level 1
Level 1

Turns out I had the wrong APN name. my original configuration works.  Only other change i did was switch from 3G to 4G.  Thanks for taking a look!

 

conf t
int cell 0/1/0
shut
exit
cell 0/1/0 lte tech lte
conf t
int cell 0/1/0
no shut

Hello,

 

good to know you got it resolved...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card