cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3501
Views
0
Helpful
3
Replies
Highlighted
Beginner

Accessing Web Interface on ADSL Modem in Bridged Mode

Hoping someone can either tell me how to do this or why it isn't possible.

Using Cisco 1811W with IOS 15.1(4)M5.  FE0 and FE1 are connected to the internet via Billion ADSL2+ modems operating in bridged mode.  Both lines are similar so I'll only discuss FE0 from this point on.

Local subnet is 192.168.128.0/24 with router on 192.168.128.1 as default gateway.  Modem on FE0 has static LAN IP of 192.168.128.2 and when plugged into the switch on the LAN side, the web interface can be accessed at that IP address.  Unplug the modem from the switch and plug it into FE0 and it now works as desired providing access from the router to the internet but the web interface is no longer accessable at 192.168.128.2

I tried adding a static route "ip route 192.168.128.2 255.255.255.255 FastEthernet 0" and also "ip route 192.168.128.2 255.255.255.255 Dialer 1"  Neither worked and presumably it isn't that straight forward.  Possibly NAT or other routing configuration required.

Although there isn't much to configure when in bridged mode, I mostly want this setup so I can look at the ADSL connection status and for the modem to write messages to syslog (works when plugged into switch on LAN side), or SNMP access.

Would have thought this wouldn't be an uncommon request but can't find a relevant How-To or FAQ covering the topic.

Thanks for any pointers or other assistance.

3 REPLIES 3
Highlighted
Rising star

Hi,

Access to a modem in bridged mode as far I know not available. Only if you configure it as router and give to it 192.168.1.2 ip address? connect it one switch port. Cisco router 192.168.1.1 as default gateway and set ip routing:

ip route 0.0.0.0 0.0.0.0 192.168.1.2

on cisco router.

After I think you can access to ADSL modem.

Please rate helpful posts.

Best regards,
Abzal
Highlighted

Hi Abzal,

Accessing these modems while in bridged mode works fine providing they are on the same subnet.  i.e., if the browser and the modem are plugged into the same switch, I can use the modem's web interface to look at the ADSL connection stats.

However, when the modem is being used by the router to connect to the internet, it is moved to the "WAN side" of the router and no longer responds on it's LAN IP address, presumably because the packets aren't being sent out through the WAN port.

I hoped to achieve this by setting the static route but this didn't work.  Either the packets aren't getting there, or NAT is screwing something up, or the response packets aren't getting back.

I'm not familiar enough with the Cisco router to know what's not configured correctly, or if it just isn't possible.  Hoping someone whose done this before can provide some guidance.

Highlighted

Hi peter,

It happens because when you connect ADSL to WAN it gets public ip from ISP. I don't think possible. Only way configure it as router instead of bridge. In bridge mode modem becomes dumb just forwarding frames coming from one port to another.

No any logic.

Please rate helpful posts.

Best regards,
Abzal