cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
893
Views
0
Helpful
7
Replies

Additional ADSL connection on existing BGP on the same router, same ISP

cinmar1957
Level 1
Level 1

I have 2 leaseline which is configured using BGP. and I would like to use an extra ADSL connection for HTTP request only.

MAIN and BACKUP leaseline is configured using BGP with no issues.

-> ip nat inside source route-map BACKUP interface FastEthernet0/1/1 overload

-> ip nat inside source route-map MAIN interface GigabitEthernet0/1 overload

Since I have an extra ADSL line I am adding this statement:

ip nat inside source route-map ADSL interface Dialer1 overload

NOTE: All interfaces are tested individually without issues.

Overall my configuration for the 3 connecction are:

ip nat inside source route-map ADSL interface Dialer1 overload

ip nat inside source route-map BACKUP interface FastEthernet0/1/1 overload

ip nat inside source route-map MAIN interface GigabitEthernet0/1 overload

But, when I do show ip route, the defaul gateway will go to ADSL not the BGP,

Disabling the ADSL, the default gateway returns back to BGP.

My question, can I keep the BGP route as default while keeping the ADSL for http traffic on the same router?


1 Accepted Solution

Accepted Solutions

I forgot to mention that you need to also remove the "ppp ipcp route default" statement from the Dialer1 interface so that a default route is not installed through this interface.

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

7 Replies 7

Harold Ritter
Cisco Employee
Cisco Employee

Hi,

You probably get your default route via DHCP or static route, which makes it normal for this route to be preferred over the default received via BGP. You would need to use PBR to send the HTTP traffic via the ADSL link. Normal routing will not help here.

Regards

http://www.cisco.com/en/US/docs/switches/metro/me3600x_3800x/software/release/15.3_3_S/configuration/guide/swpbr.html

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

This is my configuration:

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description ADSL

no ip address

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 10

!

interface GigabitEthernet0/1

description MAIN_LEASELINE

ip address 11.11.11.11 255.255.255.252

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/1/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/1

description BACKUP_LEASELINE

ip address 22.22.22.22 255.255.255.252

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/0/0

no ip address

!

interface GigabitEthernet0/0/1

switchport access vlan 2

no ip address

!

interface GigabitEthernet0/0/2

switchport access vlan 3

no ip address

!

interface GigabitEthernet0/0/3

switchport access vlan 4

no ip address

!

interface Vlan1

description VLAN PRIVATE NETWORK

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip policy route-map TOADSL

!

interface Vlan2

  no ip address

!

interface Vlan3

  no ip address

!

interface Vlan4

  no ip address

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly in max-fragments 64 max-reassemblies 512

encapsulation ppp

dialer pool 10

ppp authentication pap callin

ppp pap sent-username xxx password 7 xxxxx

ppp ipcp dns request accept

ppp ipcp route default

ppp ipcp address accept

ip policy route-map

!

!

router bgp 200

bgp log-neighbor-changes

network 111.111.111.111 mask 255.255.255.248

network 222.222.222.222 mask 255.255.255.248

neighbor 11.11.11.10 remote-as 100

neighbor 11.11.11.10 update-source GigabitEthernet0/1

neighbor 11.11.11.10 route-map MAINLL in

neighbor 22.22.22.21 remote-as 100

neighbor 22.22.22.21 update-source FastEthernet0/1/1

neighbor 22.22.22.21 route-map BACKUPLL in

maximum-paths 2

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

ip dns server

ip nat inside source route-map BACKUP interface FastEthernet0/1/1 overload

ip nat inside source route-map MAIN interface GigabitEthernet0/1 overload

ip nat inside source route-map ADSL interface Dialer1 overload

!

access-list 1 permit any

access-list 101 permit tcp host 192.168.1.0 0.0.0.255 any eq www

access-list 101 deny   ip any any

!

!

!

!

route-map MAIN permit 10

match ip address 1

match interface GigabitEthernet0/1

!

route-map MAINLL permit 10

set local-preference 110

!

route-map BACKUP permit 10

match ip address 1

match interface FastEthernet0/1/1

!

route-map BACKUPLL permit 10

set local-preference 90

!

route-map TOADSL permit 10

match ip address 101

match interface Dialer1

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

Harold Ritter
Cisco Employee
Cisco Employee

Hi,

You need to change the "match interface Dialer1" to "set interface Dialer1" in the TOADSL route-map that is used for PBR. You also need to have a "ip nat inside source" statement for the Dialer1 interface, which deleted from the configuration.

ip nat inside source route-map ADSL interface Dialer1 overload

route-map ADSL permit 10

match interface Dialer1

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi Harold,

Thank you for the  quick reply.

I modified the configuration as what you've suggested. But still with no luck. When I do 's ip route' the default gateway is the ADSL not via BGP.

Here is the edited config.

This is my configuration:

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description ADSL

no ip address

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 10

!

interface GigabitEthernet0/1

description MAIN_LEASELINE

ip address 11.11.11.11 255.255.255.252

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/1/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/1

description BACKUP_LEASELINE

ip address 22.22.22.22 255.255.255.252

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/0/0

no ip address

!

interface GigabitEthernet0/0/1

switchport access vlan 2

no ip address

!

interface GigabitEthernet0/0/2

switchport access vlan 3

no ip address

!

interface GigabitEthernet0/0/3

switchport access vlan 4

no ip address

!

interface Vlan1

description VLAN PRIVATE NETWORK

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip policy route-map TOADSL

!

interface Vlan2

  no ip address

!

interface Vlan3

  no ip address

!

interface Vlan4

  no ip address

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly in max-fragments 64 max-reassemblies 512

encapsulation ppp

dialer pool 10

ppp authentication pap callin

ppp pap sent-username xxx password 7 xxxxx

ppp ipcp dns request accept

ppp ipcp route default

ppp ipcp address accept

ip policy route-map

!

!

router bgp 200

bgp log-neighbor-changes

network 111.111.111.111 mask 255.255.255.248

network 222.222.222.222 mask 255.255.255.248

neighbor 11.11.11.10 remote-as 100

neighbor 11.11.11.10 update-source GigabitEthernet0/1

neighbor 11.11.11.10 route-map MAINLL in

neighbor 22.22.22.21 remote-as 100

neighbor 22.22.22.21 update-source FastEthernet0/1/1

neighbor 22.22.22.21 route-map BACKUPLL in

maximum-paths 2

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

ip dns server

ip nat inside source route-map BACKUP interface FastEthernet0/1/1 overload

ip nat inside source route-map MAIN interface GigabitEthernet0/1 overload

ip nat inside source route-map ADSL interface Dialer1 overload

!

access-list 1 permit any

access-list 101 permit tcp host 192.168.1.0 0.0.0.255 any eq www

access-list 101 deny   ip any any

!

!

!

!

route-map MAIN permit 10

match ip address 1

match interface GigabitEthernet0/1

!

route-map MAINLL permit 10

set local-preference 110

!

route-map BACKUP permit 10

match ip address 1

match interface FastEthernet0/1/1

!

route-map BACKUPLL permit 10

set local-preference 90

!

route-map TOADSL permit 10

match ip address 101

set interface Dialer1

!

route-map ADSL permit 10

match ip address 1

match interface Dialer1

!

!

!

control-plane

!

!

!

line con 0

line aux 0

I forgot to mention that you need to also remove the "ppp ipcp route default" statement from the Dialer1 interface so that a default route is not installed through this interface.

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi Harold,

Youre a life saver. Thank you so much...

You are very welcome.

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco