02-12-2006 11:00 AM - edited 03-03-2019 11:43 AM
Sakhr#sh runn
Sakhr#sh running-config
Building configuration...
Current configuration : 2018 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Sakhr
!
boot-start-marker
boot-end-marker
!
enable secret xxxx
!
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
no crypto isakmp enable
!
!
!
!
interface Ethernet0
ip address 192.168.20.1 255.255.255.0 secondary
ip address 213.132.133.33 255.255.255.248
ip accounting output-packets
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/33
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
mtu 1492
ip address 10.1.6.102 255.255.255.252
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
!
ip nat inside source list 10 interface Ethernet0 overload
ip nat inside source static 192.168.20.227 213.132.133.34 extendable
ip nat inside source static 192.168.20.146 213.132.133.35 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.6.101
ip http server
no ip http secure-server
!
!
access-list 10 permit 192.168.20.0 0.0.0.255
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
login local
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
!
end
I can reach my ISP but cannot browse to the ouside world.
I configuring my DSL router ...but seems everything is ok ...but nothing working
I have checked ...even the configurations at ISP site ...and they are just perfectly fine ...something wrong at my end only
02-12-2006 11:29 AM
Hello,
the following statement in your configuration doesn´t look right:
ip nat inside source list 10 interface Ethernet0 overload
Try and change that to:
ip nat inside source list 10 interface Dialer0 overload
Also, there is a secondary address on your Ethernet0 interface that appears to be a public IP, what is that used for ?
Sakhr#sh runn
Sakhr#sh running-config
Building configuration...
Current configuration : 2018 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Sakhr
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Y/jP$/yi6/NGrMFQZ07KMO.C2n/
!
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
no crypto isakmp enable
!
!
!
!
interface Ethernet0
ip address 192.168.20.1 255.255.255.0 secondary
ip address 213.132.133.33 255.255.255.248
ip accounting output-packets
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/33
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
mtu 1492
ip address 10.1.6.102 255.255.255.252
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
!
-->ip nat inside source list 10 interface Dialer0 overload
ip nat inside source static 192.168.20.227 213.132.133.34 extendable
ip nat inside source static 192.168.20.146 213.132.133.35 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.6.101
ip http server
no ip http secure-server
!
!
access-list 10 permit 192.168.20.0 0.0.0.255
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
login local
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
!
end
Regards,
Nethelper
02-12-2006 12:10 PM
ip nat inside source list 10 interface Ethernet0 overload
This statement is right coz the ethernet0 is configured with public ip addresses.
ip nat inside source list 10 interface Dialer0 overload
This statement is wrong ...coz the dialer is not configured with public ip addresses....How will I go the the internet???
ip address 192.168.20.1 255.255.255.0 secondary is the LAN ip's which is natted to the public ip address.
I have many router configuratons which work ...but this one is quite strange
02-12-2006 12:37 PM
Hello,
I don´t understand your setup, is the DSL line a second line to a different provider ?
If your provider is connected to the Ethernet0 interface, try the following configuration:
Sakhr#sh runn
Sakhr#sh running-config
Building configuration...
Current configuration : 2018 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Sakhr
!
boot-start-marker
boot-end-marker
!
enable secret xxxx
!
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
no crypto isakmp enable
!
!
!
-->interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.20.1 255.255.255.0 secondary
ip address 213.132.133.33 255.255.255.248
ip accounting output-packets
-->ip nat outside
ip tcp adjust-mss 1452
hold-queue 100 out
-->ip policy route-map ISP
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/33
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
mtu 1492
ip address 10.1.6.102 255.255.255.252
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
!
ip nat inside source list 10 interface Ethernet0 overload
ip nat inside source static 192.168.20.227 213.132.133.34 extendable
ip nat inside source static 192.168.20.146 213.132.133.35 extendable
ip classless
-->ip route 0.0.0.0 0.0.0.0 Ethernet0
ip http server
no ip http secure-server
!
-->route-map ISP permit 10
match ip address 10
set interface Loopback0
!
access-list 10 permit 192.168.20.0 0.0.0.255
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
login local
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
!
end
Regards,
Nethelper
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide