We have an ethernet port on Cisco router 1800 connected to the ADSL modem. The router does ip nat translation, but users complained it is slow when they acess to internet.
Here is the diagram:
DSL Modem<--> F0 on the router, F1<--> switch
Here is what I tried already.
1. Called ISP, the circuit is clean
2. setup the ip mtu 1452 or 1492
2. setup different size# on ip tcp adjust-mss 1300/1350/1452
3. Directly connected the computer to the modem without any issue
4. Directly connected the computer to the port F1 on the router, and it seems the same issue.
5. Changed the ADSL to bridge mode, and run pppoe on the router, and it seems no improvement.
Here is the config:
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
ip address 10.10.10.1 255.255.255.250
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer1
ip address nego
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname ***
ppp chap password 7***
ppp pap sent-username *** password ***
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip nat inside source route-map OUT interface Dialer1 overload
access-list 115 permit ip 10.10.10.0 0.0.0.255 any
route-map OUT permit 10
math ip adddress 115
Please advise.
Regards,
Joe