Showing results for 
Search instead for 
Did you mean: 

ADSL Sync Issues With SR520

I am having trouble getting a SR520W-ADSL-K9 router installed for one of our customers.

I have installed this router in the past and have had no problems. I have what i believe to be a working config (that is currently working fine on other sites).

The only difference with this customer is that they're using BT Business Broadband, and we can't change that. BT are obviously less than helpful when it comes to issues with non-BT supplied equipment.

At present the existing BT router is syncing fine (see attached) using ADSL2+ Annex A

When it comes to the 520, i get no signs of life at all. I'm thinking (read: hoping) that there is a firmware update for the modem that will increase compatability.

I have tried this router on another ADSL2+ Annex A line and also a G.DMT line and it seems fine. However we also have a ADSL2+ Annex M line at the office and that doesnt sync either just like our customer.

This is what a show dsl interface atm 0 produces:

Alcatel 20190 chipset information

Line has not yet been activated.

Modem Status:    Down (DMTDSL_DO_OPEN)

DSL Mode:        Unknown
Interrupts:      573269 (0 spurious)
PHY Access Err:  0
Activations:     0
LED Status:      OFF
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded

With debug atm states on i get this
DSL(ATM0): 1: Modem state = 0x8

I have tried dsl operating mode auto, and also dsl operating mode adsl2+

Please can someone help me out?! This is the first problem i've had with cisco gear, and i don't know what else to do :/


Hey Paul,

I am having the same problem on an ADSL2+ Annex M line. I have tried all available operating modes available as listed below, but can only get it to sync when set to 'auto'. The rest fail with the same status as yours 'DSL Mode: Unknown'. Annex M ADSL 2+ works perfectly fine on a pile of other standard DSL modems I have lying around.

SR520(config-if)#dsl op ?
  adsl2     ITU G.992.3 Annex A and L
  adsl2+    ITU G.992.5 Annex A
  ansi-dmt  ANSI T1.413
  auto      auto detect mode
  itu-dmt   ITU G.992.1 Annex A

Did you find a solution to this, or can anybody else point me in the right direction?


Hi Richard,

I did figure this out myself in the end. As i suspected, it was a modem firmware update.

I don't understand why i cannot download the files i need from the cisco site. It seems to suggest i need a support contract for this. I dont understand why, since the files will be no use to anyone without this router, and then don't add additional features.

Either way, locate the Alcatel 20190 firmware. The filename to look for is adsl_alc_20190.bin.4.0.15.bin

Rename this file to adsl_alc_20190.bin so it can be picked up by the router.

Then TFTP to the file to the router. Reload, and you should see something like this in your "show dsl interface atm 0"

show dsl interface atm 0

Init FW:         init_AMR_4.0.015.bin
Operation FW:    AMR-E-4.0.015.bin
FW Source:       external
FW Version:      4.0.15

After this, my modem synced perfectly.

If you run into any problems, just delete the adsl_alc_20190.bin from flash, and it will revert to the embedded firmware.


Hi Paul,

Just this afternoon I did end up getting sync with operating-mode adsl2+ by setting sync mode to ITU as seen below (I assume it was either on ANSI or just not specified at all) however, the speeds are terrible compared to other dsl modems I have on adsl2+

SR520(config)#int atm0
SR520(config-if)#dsl sync mode ?
  ansi  Prefer ANSI over ITU
  itu   Prefer ITU over ANSI/ETSI

SR520(config-if)#dsl sync mode itu

Many thanks for the advice on the firmware, I am still running AMR-3.0.014.bin so I will assume this is the cause of the speed problems and upgrade to the firmware you suggested. I agree with you on the support contract, the firmware updates should be freely available to somebody that owns the device.


Hi Guys,

I am having a similar issue with three SR520 routers. I have the routers with the ADSLoPOTS connections and my issues are centred around the ADSL connection dropping at least twice a day. The only way I can currently fix this is to reload the routers.

All three are showing the same characteristics so I am thinking that my first point of call should be a firmware upgrade.

My current .bin file is this - sr520-advipservicesk9-mz.124-20.T5.bin

Now I'm pretty new to Cisco syntax so not entirely sure on two things:

A. Where do I find a new .bin version?

B. How to I load it?

Any advice anyone can give me would be great.

PS. Attached is the config I am currently using, which I think is fine but maybe an ADSL setting is missing/wrong?


Chris Snape


Hi Chris,

I would suggest updating to the latest IOS first and also follow Paul's  steps above to update the Alcatel firmware. I also hope you have tried a  standard modem to rule out any possible fault on the line. The latest IOS for SR520 is sr520-advipservicesk9-mz.124-24.T4.bin and you will need to purchase SMARTnet contract to obtain this from the Cisco website. Apart from this, I have ditched the Cisco SR520 and changed to using the Cisco ASA5505 with a standard modem attached so cannot be of much more help to you sorry.




I have upgraded the Alcatel Modem firmware on all three and so far so good!

Will keep you posted. Thanks.

Content for Community-Ad