cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2016
Views
0
Helpful
9
Replies

ASA 5505 new password not going into effect.

amdc42970
Beginner
Beginner

I'm trying to change the login password and enable password for our cisco asa 5505. Both commands "passwd" and "enable password" finishes successfully without any errors. After we save the configuration, exit and try to login back again, only the old password works. Please help.

1 Accepted Solution

Accepted Solutions

asa (config)# username abc password YOURNEWPASSWORD

 

View solution in original post

9 Replies 9

Karsten Iwen
VIP Mentor VIP Mentor
VIP Mentor

The password configured with "passwd" is the Telnet-password that is typically not used any more.

The password configured with "enable password" is used when you change to privileged mode, but is not used to log in to the ASA. How do you login? With username/password? Then you have to look at your "username" statements. Or do you have a central authentication-server? If that is used, then it could be that the local passwords are not used.

Thank you for youre reply. After changing the password, I did try logging in using telnet. Only the old password worked.

I login with a username and password. How do I find out if the ASA is using a central authentication-server?

 

When you use a username to login, then the "passwd" is not used. If your username is not locally configured, then it's likely that you use a central server for that.

With

show run aaa

you can see which authentication-server-group is used. With

show run aaa-server

you see which server it uses.

show run aaa

aaa authentication enable console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
aaa authentication telnet console LOCAL
aaa authorization command LOCAL

 

show run aaa-server

this command doesn't show any answer. It just comes back to the command prompt.

 

I'm logging in with username "abc" and some password "def". All I want to just change this password and then the enable password.

 

Then you have to change the password of the user "abc".

I'm sorry, how do I do that?

asa (config)# username abc password YOURNEWPASSWORD

 

Thank you !!! That worked.

username abc password dfsdfdsfsdfsdfsdfsdf encrypted privilege 15

Above is the only username statement I see when I run the show run command.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: