04-21-2020 02:27 AM - edited 04-21-2020 02:34 AM
Hi
Please can you advise me how can i nat the inside hairpin traffic on ASA , and the web server allow only https traffic
Please see the attached image of the network diagram
Solved! Go to Solution.
04-21-2020 02:41 AM
04-21-2020 05:43 AM
Hello,
below is what you would need for hairpinning HTTPS:
same-security-traffic permit intra-interface
!
interface GigabitEthernet0/1
nameif inside
security level 100
ip address 192.168.100.1 255.255.255.0
!
interface GigabitEthernet0/0
nameif outside
security level 0
ip address 80.200.122.100 255.255.255.0
!
object network WEBSERVER_PUBLIC
host 80.200.122.100
!
object network WEBSERVER_LOCAL
host 192.168.100.100
!
object service HTTPS
service tcp destination eq https
!
object-group network LOCAL_HOSTS
network-object 192.168.100.0 255.255.255.0
!
nat (inside,inside) source dynamic LOCAL_HOSTS interface destination static WEBSERVER_PUBLIC WEBSERVER_LOCAL service HTTPS HTTPS
04-21-2020 02:41 AM
04-21-2020 03:02 AM
Dear RJI
Thanks its working now i can browse only the home page of website
https://www.XXXXXXXXXXX.com working fine
and when i click log in page not working
https://www.XXXXXXXXXXX.com/portal/login
please can you advise me
thank you
04-21-2020 03:14 AM
04-21-2020 03:30 AM
192.168.100.100 it's a web server and its rewrite to Https only and we dont have domain server to dns resolve
04-21-2020 04:44 AM
04-21-2020 05:43 AM
Hello,
below is what you would need for hairpinning HTTPS:
same-security-traffic permit intra-interface
!
interface GigabitEthernet0/1
nameif inside
security level 100
ip address 192.168.100.1 255.255.255.0
!
interface GigabitEthernet0/0
nameif outside
security level 0
ip address 80.200.122.100 255.255.255.0
!
object network WEBSERVER_PUBLIC
host 80.200.122.100
!
object network WEBSERVER_LOCAL
host 192.168.100.100
!
object service HTTPS
service tcp destination eq https
!
object-group network LOCAL_HOSTS
network-object 192.168.100.0 255.255.255.0
!
nat (inside,inside) source dynamic LOCAL_HOSTS interface destination static WEBSERVER_PUBLIC WEBSERVER_LOCAL service HTTPS HTTPS
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide