Showing results for 
Search instead for 
Did you mean: 

ASR router software upgrade licensing problems


I've an ASR 1001 router currently running software image:


I've tried upgrading to:



In both cases the device "loses" it's Advanced IP services license when it's reloaded into the more recent release.

ldn-sh-gw2#show license

License Store: Primary License Storage

StoreIndex:  0          Feature: advipservices                     Version: 1.0

License Type: Permanent

License State: Active, In Use

License Count: Non-Counted

License Priority: Medium

License Store: Primary License Storage

StoreIndex:  1          Feature: sw_redundancy                     Version: 1.0

License Type: Permanent

License State: Active, Not in Use

License Count: Non-Counted

License Priority: Medium

Am I missing something?

- Matt


Exactly the same problem! I haven't found anything yet.....

UPD: The method is very easy....

1. You should type next command under factory loaded IOS which contains a licence:

Router#license save file bootflash:license.lic 

2. Then install your new universal image and boot it.You will see next boot message:

License Level: ipbase
License Type: Default. No valid license found.
Next reload license Level: ipbase

3. Type the next command under new image:

Router#license install bootflash:license.lic
Installing licenses from "bootflash:license.lic" 

Aug 13 01:08:48.841: %LICENSE-6-INSTALL: Feature advipservices 1.0 was installed in this device. UDI=ASR1001:JAE162601MX; StoreIndex=0:Primary License Storage

Aug 13 01:08:48.847: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = asr1001 Next reboot level = advipservices and License = advipservices

4. Reload IOS.

5. Finish!

This is the exact same problem that I am having and your post solved it 100% Excellent work

Alexander Stadnikov

Unfortunately, software feature licensing for the ASR is quite different from Cisco's other products (particularly previous router platforms). IPSEC is not included in the Advanced IP Services feature set and has to be licensed seperately.

The ASR purchasing guide mentions this, but some resellers are not warning customers at the time of purchase:

Cisco have since introduced additional licensing enforcement, covering the IPSEC feature, between point releases in the same train. This is barely mentioned in the release notes. You can literally upgrade your system in production and find that your VPNs stop working. The only solution is to buy the IPSEC license, apply it to the system, then reload your device.

Sorry for the bad news. I spoke to TAC about it at some length and they verified this is the case. It's a pretty poor show, in my opinion. This is not a good way to treat your customers; the change in licensing policy should at least be clearly mentioned in the documentation and release notes.

Just read previous updated message! 

I have made upgraded from asr1001-universal.03.05.01.S.152-1.S1.bin to asr1001-universalk9.03.07.02.S.152-4.S2.bin -> successfully!

And 5 minute ago have tried with asr1001-universalk9.03.09.01.S.153-2.S1.bin - also successfully!

We are not using VPNs with encryption. Other features working fine. ASR is using as access node for Internet/MPLS-VPN customers.

Try the method above and describe your experience later if possible.

Good luck!

Sounds like you may have had a license, but perhaps it was being dropped when upgrading to certain specific releases. Unfortunately for us, we found out that we simply didn't have an IPSEC license to begin with :-(

Anyway, glad to hear you are up and working.

- Matt

My issue is exactly the same as described in your first message. The IOS universal.03.05.01.S.152-1.S1 was factory loaded with Advanced IP services license, but upgrading to more recent release resets license to ipbase....