11-19-2015 12:49 PM - edited 03-05-2019 02:47 AM
Hi,
I hope that someone can help me resolving this issue that I'm having with RTBH, this is my scneario:
R1 ---(RIPv2)--- R3 ---(RIPv2/iBGP)--- R2
R3 --- PC
The PC is making a DDnS to R1 loopback address (150.1.10.1/32)
I want to implement RTBH but I have no idea why is not working, let me share with you the configurations:
R1:
interface Loopback0
ip address 150.1.1.1 255.255.255.255
ipv6 address 2001:150:1:1::1/128
!
interface Loopback1
ip address 150.1.10.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 136.1.13.1 255.255.255.0
duplex full
speed 1000
media-type gbic
negotiation auto
ipv6 address 2001:136:1:13::1/64
!
router rip
version 2
network 136.1.0.0
network 150.1.0.0
no auto-summary
!
R3:
interface Loopback0
ip address 150.1.3.3 255.255.255.255
ipv6 address 2001:150:1:3::3/128
!
interface Null0
no ip unreachables
!
interface GigabitEthernet0/0
ip address 136.1.13.3 255.255.255.0
duplex full
speed 1000
media-type gbic
negotiation auto
ipv6 address 2001:136:1:13::3/64
!
interface GigabitEthernet1/0
ip address 136.1.23.3 255.255.255.0
negotiation auto
ipv6 address 2001:136:1:23::3/64
!
interface GigabitEthernet2/0
ip address 10.1.0.3 255.255.255.0
negotiation auto
ipv6 address 2001:10:1::3/64
!
router rip
version 2
network 10.0.0.0
network 136.1.0.0
network 150.1.0.0
no auto-summary
!
router bgp 23
no synchronization
bgp log-neighbor-changes
neighbor 150.1.2.2 remote-as 23
neighbor 150.1.2.2 update-source Loopback0
no auto-summary
!
ip route 192.0.2.1 255.255.255.255 Null0
!
R2:
interface Loopback0
ip address 150.1.2.2 255.255.255.255
ipv6 address 2001:150:1:2::2/128
!
interface GigabitEthernet1/0
ip address 136.1.23.2 255.255.255.0
negotiation auto
ipv6 address 2001:136:1:23::2/64
!
router rip
version 2
network 136.1.0.0
network 150.1.0.0
no auto-summary
!
router bgp 23
no synchronization
bgp log-neighbor-changes
redistribute static route-map rbht
neighbor 150.1.3.3 remote-as 23
neighbor 150.1.3.3 update-source Loopback0
neighbor 150.1.3.3 send-community
no auto-summary
!
ip route 150.1.10.1 255.255.255.255 Null0 tag 666
ip route 192.0.2.1 255.255.255.255 Null0
!
route-map rtbh permit 10
match tag 666
set local-preference 200
set origin igp
set community no-export
set ip next-hop 192.0.2.1
Thanks :D
09-27-2018 03:45 PM - edited 09-27-2018 03:45 PM
Two things:
1. It's because you're not redistributing BGP int RIP.
router rip redistribute bgp 23 metric 5
2. You're trying to redistribute iBGP into RIP. You can only distribute eBGP into RIP, unless you use a special override command:
router bgp 23
bgp redistribute-internal
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide