cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
566
Views
0
Helpful
3
Replies

BGP routing issues

Maurice Ball
Level 3
Level 3

Could someone please explain to me why I can not route between router R1 and R5.   

Any help at all would be greatly appreciated. 

Here is the ip bgp table from R1

R1#
R1#sh ip bgp
BGP table version is 7, local router ID is 100.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

  Network          Next Hop            Metric LocPrf Weight Path
*>i50.1.1.0/24      4.4.4.4                  0    700      0 6500 i
*> 100.1.1.0/24    0.0.0.0                  0        32768 i
*>i200.1.1.0        4.4.4.4                  0    700      0 6500 ?
*>i200.1.3.0        4.4.4.4                  0    700      0 6500 ?
*>i200.1.5.0        4.4.4.4                  0    700      0 6500 ?
*>i200.1.7.0        4.4.4.4                  0    700      0 6500 ?
R1#

*********************************************************************

The topology and BGP configuration files are listed below.

BGPTopolgy.JPG

The following is how I have it configured  AS 5500

I am running BGP and OSPF on R1 and R4. On router R3 and R2 I am only running OSPF.

The OSPF protocol is only advertising the following networks:

10.1.12.0/29

10.1.13.0/29

10.1.24.0/29

10.1.34.0/29

10.1.45.0/29

10.1.46.0/29

1.1.1.1/32

4.4.4.4/32

100.1.1.0/24

************************************

R1 Config

interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

interface Loopback100

ip address 100.1.1.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.1.13.1 255.255.255.248

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 10.1.12.1 255.255.255.248

clock rate 2000000

!

interface Serial0/2

no ip address

shutdown

clock rate 2000000

!

interface Serial0/3

no ip address

shutdown

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.1.12.0 0.0.0.7 area 0

network 10.1.13.0 0.0.0.7 area 0

network 100.1.1.0 0.0.0.255 area 0

!

router bgp 5500

no synchronization

bgp log-neighbor-changes

network 100.1.1.0 mask 255.255.255.0

neighbor 4.4.4.4 remote-as 5500

neighbor 4.4.4.4 ebgp-multihop 5

neighbor 4.4.4.4 update-source Loopback1

no auto-summary

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

******************************************

R4 Config

!

!

interface Loopback4

ip address 4.4.4.4 255.255.255.255

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.1.46.1 255.255.255.248

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 10.1.34.2 255.255.255.248

clock rate 2000000

!

interface Serial0/2

ip address 10.1.24.2 255.255.255.248

clock rate 2000000

!

interface Serial0/3

ip address 10.1.45.1 255.255.255.248

clock rate 2000000

!

router ospf 1

log-adjacency-changes

redistribute connected subnets

network 4.4.4.4 0.0.0.0 area 0

network 10.1.24.0 0.0.0.7 area 0

network 10.1.34.0 0.0.0.7 area 0

!

router bgp 5500

no synchronization

bgp default local-preference 700

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 5500

neighbor 1.1.1.1 update-source Loopback4

neighbor 1.1.1.1 next-hop-self

neighbor 5.5.5.5 remote-as 6500

neighbor 5.5.5.5 ebgp-multihop 4

neighbor 5.5.5.5 update-source Loopback4

no auto-summary

!

ip forward-protocol nd

ip route 5.5.5.5 255.255.255.255 10.1.45.2

ip route 5.5.5.5 255.255.255.255 10.1.46.2

!

!

************************************

R5 Config

!

interface Loopback0

ip address 200.1.0.1 255.255.255.0

!

interface Loopback1

ip address 200.1.1.1 255.255.255.0

!

interface Loopback2

ip address 200.1.2.1 255.255.255.0

!

interface Loopback3

ip address 200.1.3.1 255.255.255.0

!

interface Loopback4

ip address 200.1.4.1 255.255.255.0

!

interface Loopback5

ip address 5.5.5.5 255.255.255.255

!

interface Loopback6

ip address 200.1.6.1 255.255.255.0

!

interface Loopback7

ip address 200.1.7.1 255.255.255.0

!

interface Loopback10

ip address 50.1.1.1 255.255.255.0

!

interface Loopback11

ip address 200.1.5.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.1.46.2 255.255.255.248

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 10.1.45.2 255.255.255.248

clock rate 2000000

!

router bgp 6500

no synchronization

bgp log-neighbor-changes

network 50.1.1.0 mask 255.255.255.0

redistribute connected route-map AllowNetwork

neighbor 4.4.4.4 remote-as 5500

neighbor 4.4.4.4 ebgp-multihop 4

neighbor 4.4.4.4 update-source Loopback5

no auto-summary

!

ip forward-protocol nd

ip route 1.1.1.1 255.255.255.255 10.1.45.1

ip route 1.1.1.1 255.255.255.255 10.1.46.1

ip route 4.4.4.4 255.255.255.255 10.1.45.1

ip route 4.4.4.4 255.255.255.255 10.1.46.1

!

!

no ip http server

no ip http secure-server

!

ip access-list standard ISPNETWORK

permit 200.1.1.0

permit 200.1.3.0

permit 200.1.5.0

permit 200.1.7.0

deny  any

!

!

!

!

route-map AllowNetwork permit 10

match ip address ISPNETWORK

!

!

!

!

control-plane

!

!

2 Accepted Solutions

Accepted Solutions

Raju Sekharan
Cisco Employee
Cisco Employee

Hi

For R1 to Reach R5, it has to go via R2 or R4 and both of them doesn't have the route to R5 prefixes and they will drop the packets

Thanks

Raju

View solution in original post

yes. or you should run BGP on all the 4 routers.

Look at below link which mentiones that "

You can also disable synchronization if all routers in your AS run BGP"

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml#synch

Thanks

Raju

View solution in original post

3 Replies 3

Raju Sekharan
Cisco Employee
Cisco Employee

Hi

For R1 to Reach R5, it has to go via R2 or R4 and both of them doesn't have the route to R5 prefixes and they will drop the packets

Thanks

Raju

So I must advertise all R5 loopback interfaces on R2 and R3 with the OSPF routing protocol, for R1 to be able to reach the loopbacks on R5?

yes. or you should run BGP on all the 4 routers.

Look at below link which mentiones that "

You can also disable synchronization if all routers in your AS run BGP"

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml#synch

Thanks

Raju