12-20-2014 07:19 AM - edited 03-05-2019 12:25 AM
I have 2 ISPS conect to one router.
ISP1 = 100MB fiber link
ISP2 = bonded pair of t1's
The issue is no matter what type of route i try to do, If I physically unplug ISP1, nothing is able to route out from anything behind the router. I am however to ping outside so im not sure why its not routing outbound traffic.. ISP2 is for multihoming purposes of BGP but to be there as a redundany link to everything where we would be able to support our clients who have VoIP through us.
I am not sure what the issue is, unfortunately I do not have any support system for this. Basically the way it should work is that if are Fiber goes down (which is going to happen sometime tonight as they are performing maintenance) the Bonded T1's will take over.
The config is as follows, Thank you for the help.
edundancy
!
!
controller T1 0/0/0
cablelength long 0db
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
cablelength long 0db
channel-group 0 timeslots 1-24
!
ip ssh version 2
!
!
!
!
interface Multilink1
description T1 Backup
bandwidth inherit
ip address xxx.xxx.xxx.xxx 255.255.255.252
ppp multilink
ppp multilink group 1
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Primary
ip address yyy.yyy.yyy.yyy 255.255.255.252
duplex full
speed 1000
!
interface GigabitEthernet0/1
description WAN Switch
ip address xxx.xxx.xxx.xxx 255.255.255.192 secondary
ip address xxx.xxx.xxx.xxx 255.255.255.128
duplex full
speed 1000
!
interface GigabitEthernet0/2
ip address xxx.xxx.xxx.xxx 255.255.255.192
duplex full
speed auto
!
interface Serial0/0/0:0
description T1-1
bandwidth 1544
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Serial0/0/1:0
description T1-2
bandwidth 1544
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
router bgp #####
bgp log-neighbor-changes
network XXX.XXX.XXX.XXX
neighbor xxx.xxx.xxx.xxx remote-as 111111
neighbor xxx.xxx.xxx.xxx description PRIMARY BGP
neighbor xxx.xxx.xxx.xxx password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
neighbor xxx.xxx.xxx.xxx soft-reconfiguration inbound
neighbor xxx.xxx.xxx.xxx route-map Corp-BGP-Mid-in in
neighbor xxx.xxx.xxx.xxx route-map Corp-BGP-Mid-out out
neighbor xxx.xxx.xxx.xxx maximum-prefix 200
neighbor yyy.yyy.yyy.yyy remote-as 222222
neighbor yyy.yyy.yyy.yyy description BACKUP BGP
neighbor yyy.yyy.yyy.yyy password 7 xxxxxxxxxxxxxxx
neighbor yyy.yyy.yyy.yyy update-source Multilink1
neighbor yyy.yyy.yyy.yyy soft-reconfiguration inbound
neighbor yyy.yyy.yyy.yyy route-map Corp-BGP-ACDin in
neighbor yyy.yyy.yyy.yyy route-map Corp-BGP-ACD-out out
neighbor yyy.yyy.yyy.yyy maximum-prefix 200
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no ip nat service sip udp port 5060
ip route xxx.xxx.xxx.xxx 255.255.255.0 ###.###.### *(Fiber Gateway)*
ip route xxx.xxx.xxx.xxx 255.255.255.0 ###.###.### *Bonded t1's Gateway)*
!
!
ip prefix-list Corp-BGP-ACD-in seq 10 deny XXX.XXX.XXX.XXX/24
ip prefix-list Corp-BGP-ACD-in seq 20 permit 0.0.0.0/0
ip prefix-list Corp-BGP-ACD-in seq 30 permit 0.0.0.0/0 le 32
!
ip prefix-list Corp-BGP-ACD-out seq 10 permit XXX.XXX.XXX.XXX/24
!
ip prefix-list Corp-BGP-MidMI-in seq 10 deny XXX.XXX.XXX.XXX/24
ip prefix-list Corp-BGP-MidMI-in seq 20 permit 0.0.0.0/0
ip prefix-list Corp-BGP-MidMI-in seq 30 permit 0.0.0.0/0 le 32
!
ip prefix-list KWCorp-BGP-MidMI-out seq 10 permit XXX.XXX.XXX.XXX/24
!
route-map Corp-BGP-MidMI-in permit 10
match ip address prefix-list Corp-BGP-MidMI-in
set local-preference 110
!
route-map Corp-BGP-ACD-in permit 10
match ip address prefix-list Corp-BGP-ACD-in
!
route-map Corp-BGP-MidMI-out permit 10
match ip address prefix-list Corp-BGP-MidMI-out
!
route-map Corp-BGP-ACD-out permit 10
match ip address prefix-list Corp-BGP-ACD-out
set as-path prepend 111111 111111 111111
!
!
!
!
12-21-2014 02:42 PM
Hello
At first glance looks like you have no IGP running so the BGP is using the static routes for reachability,
So even though you have disconnected the interconnect to ISP1 the static route is still pointing out towards ISP1 lan interface .so traffic is black holing.
Using a floating static route tide in with either tracking the interface or monitoring a remote route prefix so when ISP goes down or the prefix becomes unavailable its relating tracked default route will be removed from the rib and failover towards the ISP2 default route.
I would suggest try something like this:
track 10 interface GigabitEthernet0/0line-protocol
or
ip sla 10
icmp-echo y.y.y.y source-ip x.x.x.x
timeout 2000
frequency 5
ip sla schedule 10 life forever start-time now
track 10 rtr 10 reachability
ip route xxx.xxx.xxx.xxx 255.255.255.0 ###.###.### *(Fiber Gateway)* track 10
ip route xxx.xxx.xxx.xxx 255.255.255.0 ###.###.### *Bonded t1's Gateway)* 4 (admin distance)
res
Paul
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide