cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
332
Views
0
Helpful
3
Replies

bundling and QOS

peter.saldanha
Beginner
Beginner

Hi

I have 2 serial leased lines bundled using virtual template. I want to apply a QOS Policy to serial interfaces. Where do I apply the QOS Policy? Can I apply to virtual template interface or both the serial interfaces?

rgds

3 Replies 3

thisisshanky
Advisor
Advisor

Peter, when you deal with Multilink interfaces, you need to apply the policy only on teh Multilink interface (not on serial interface). I would assume it will be the same way with Virtual templates.

http://www.cisco.com/en/US/tech/tk543/tk544/technologies_tech_note09186a0080094ad2.shtml

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Hi

I have done bundling of serial lines which works fine and also I have applied QOS based on bandwidth. I have reserved 20% bandwidth for voip traffic. I would like to know, if there is no utilisation of full 20% of bandwidth for voip, I want to use it for other traffic. How do I do this?. My configuration is as follows

Current configuration : 2818 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname crystal

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 debugging

!

username xxx privilege 15 secret xxxx

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

ip domain name yourdomain.com

no ftp-server write-enable

!

!

!

class-map match-all voip

match access-group 100

class-map match-all mail

match access-group 103

class-map match-all secureweb

match access-group 102

class-map match-all web

match access-group 101

!

!

policy-map qos-policy

class voip

bandwidth 20

class web

bandwidth 25

class mail

bandwidth 25

class secureweb

bandwidth 25

class class-default

fair-queue

!

!

!

interface Multilink2

ip address 192.169.1.2 255.255.255.0

service-policy output qos-policy

ppp multilink

ppp multilink group 2

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 192.168.125.1 255.255.255.0

ip nbar protocol-discovery

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 64000

no ip address

encapsulation ppp

pulse-time 1

ppp multilink

ppp multilink group 2

!

interface Serial0/0/1

bandwidth 64000

no ip address

encapsulation ppp

clockrate 2000000

pulse-time 1

ppp multilink

ppp multilink group 2

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.169.1.1

ip http server

ip http authentication local

!

!

access-list 100 permit udp any any range 16384 32000

access-list 100 permit tcp any any eq 1720

access-list 101 permit tcp any any eq www

access-list 101 permit tcp any any eq ftp

access-list 101 permit tcp any any eq ftp-data

access-list 102 permit tcp any any eq 443

access-list 103 permit tcp any any eq smtp

!

control-plane

!

banner login ^C

-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device. This

feature requires the one time use, initial credentials, of username "cisco"

with password "cisco".

Please change these publicly known initial credentials through SDM or IOS CLI.

Here's the Cisco IOS command:

no username cisco

NOTE: Please add a new username to be able to launch SDM for router management.

For more information about SDM please follow the instructions in the QUICK

START GUIDE for your router or at

http://www.cisco.com/go/sdm

-----------------------------------------------------------------------

^C

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

line vty 5 15

privilege level 15

login local

transport input telnet

!

end

Hi,

All the unused bandwidth will be utilised automatically according to the traffic rate. If there is congestion and voice traffic enters the interface, then voice traffic will get the allocated bandwidth.

But, in your case, I could suggest that please configure with "priority 20" command for VoIP instead of just "bandwidth 20" command. The "bandwidth" command used for CBWFQ and "priority" is for LLQ.

Regards...

-Ashok.


With best regards...
Ashok
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers