cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5785
Views
0
Helpful
4
Replies

BVI configuration on ASR1002 router

Danne1985
Level 1
Level 1

Hi Guys,

We have a cisco7206 router which is going to be replaced with an ASR1002 router. The 7206 has some interfaces in a BVI-group - the config of which i am trying to translate over into IOS XE (which runs on the ASR1002).

Basically i have the following config:

!

bridge irb

!

bridge 120 protocol ieee

!

bridge 120 route ip

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/2.120

encapsulation dot1Q 120

no ip redirects

no ip unreachables

no ip proxy-arp

bridge-group 120

!

interface GigabitEthernet0/2.3999

encapsulation dot1Q 3999

ip address 10.10.10.10 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

ip authentication mode eigrp 77 md5

ip authentication key-chain eigrp 77 XXXX

delay 1005

!

interface BVI120

ip address 172.10.10.10 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

which i am trying to find the equivalent config of, on IOS XE. The nearest answer i could find is posted here:

https://supportforums.cisco.com/thread/2162439

however this seems to work fine for physical interfaces but not for logical subinterfaces which is what i have.

FYI the 7206 is running c7200-advsecurityk9-mz.124-9.T7.bin, and the ASR1002 is running asr1000rp1-adventerprisek9.03.04.02.S.151-3.S2.bin.

Any information anyone can provide on how to translate this config from IOS to IOS XE would be much appreciated. Thanks in advance

4 Replies 4

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Danne,

the BDI concept is not limited to physical interfaces, but it uses the concept of Ethernet Virtual Connect as specified in Metro Ethernet forum

see the links below

http://www.cisco.com/en/US/docs/routers/asr1000/configuration/guide/chassis/bdi_ps9343_TSD_Products_Configuration_Guide.html#wp1146536

and

http://www.cisco.com/en/US/docs/ios-xml/ios/cether/configuration/xe-3s/asr1000/ce-ether-vc-infra-xe.html#GUID-A28FC966-6ABD-44D1-9AB6-DD0DDFC2C452

the difference should be

interface Gig0/1
   service instance 1 ethernet
     encapsulation dot1q 120
     bridge-domain 1
interface Gig0/2
   service instance 1 ethernet
     encapsulation dot1q 120
     bridge-domain 1
interface BDI1
   ip address x.x.x.x 

to be noted you can assign an encapsulation dot1q also to the BDI interface as explained in the first link.

Hope to help

Giuseppe

Thanks for the reply Giuseppe.

So are you saying that Gi0/2 that is configured like this on the 7206 router:

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/2.120

encapsulation dot1Q 120

no ip redirects

no ip unreachables

no ip proxy-arp

bridge-group 120

!

interface GigabitEthernet0/2.3999

encapsulation dot1Q 3999

ip address 10.10.10.10 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

ip authentication mode eigrp 77 md5

ip authentication key-chain eigrp 77 XXXX

delay 1005

!

interface BVI120

ip address 172.10.10.10 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

...can now be configured like this on the ASR?

interface GigabitEthernet0/2

no ip address

speed 1000

no negotiation auto

service instance 1 ethernet

  encapsulation dot1q 120

  bridge-domain 120

!

!

interface GigabitEthernet0/2.3999

encapsulation dot1Q 3999

ip address 10.10.10.10 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

ip authentication mode eigrp 77 md5

ip authentication key-chain eigrp 77 XXXX

delay 1005

!

interface BDI120

ip address 172.10.10.10 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

and i would configure Gi0/3 (which is the second interface in the bridge-domain) on the ASR similarly?

I tried creating a service instance under a subinterface but it doesnt seem to work, so this is the only way i can think of doing it that might.

Hi Danne,

Did your configuration work for you on the ASR?

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

We're you able to get this working with the sub-interface? 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: