cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

230
Views
0
Helpful
12
Replies
Highlighted
Beginner

Can access internet with router but not with PC

Hi all,  Im having an issue with my setup.   Have  ISP ---> g0/0 router g0/1 ----> switch----> PC.   I can ping google from the router but not the PC.  I can ping the ISP modem from the pc but cant seem to get past it.  Below is the routers running configuration.  Any thoughts on the issue?

 

Router#show run
Building configuration...

Current configuration : 1368 bytes
!
! Last configuration change at 20:22:24 UTC Thu Jul 30 2020
! NVRAM config last updated at 20:23:45 UTC Thu Jul 30 2020
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$7Hi6$LIodE/TUYuZHbnuUcFJp5/
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.60
ip dhcp excluded-address 192.168.1.1 192.168.1.60
!
ip dhcp pool data
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.2 4.2.2.1 8.8.8.8 8.8.4.4
!
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FGL152524ZQ
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.100.1
!
access-list 1 permit any
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Router#

12 REPLIES 12
Highlighted
VIP Mentor

Re: Can access internet with router but not with PC

Hello,

 

your ISP modem/router needs a route back to 192.168.1.0/24...

Highlighted
Beginner

Re: Can access internet with router but not with PC

Im kind of new to this.  How do I set that up?   I am using a modem that basicly has no options.  Its address is 192.168.100.1

Highlighted
VIP Mentor

Re: Can access internet with router but not with PC

Hello,

 

what brand/model is the modem? Usually, you can access it using a web browser.

Highlighted
Beginner

Re: Can access internet with router but not with PC

Its a Arris SB6141.   I can get access to it but it doesnt have any options to change or configure it.  

Highlighted
VIP Mentor

Re: Can access internet with router but not with PC

Hello,

 

the SB6141 indeed cannot be configured. Your only option is to configure your router in pure bridge mode, but I am not sure if your particular router let's you do that. The configuration would simply be as below; set the PC to DHCP and check if you get an IP address in the 192.168.100.0.24 range...

 

no ip routing
!
bridge 1 protocol ieee
!
interface GigabitEthernet0/0
bridge-group 1
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1
bridge-group 1
ip virtual-reassembly
duplex auto
speed auto

Highlighted
Beginner

Re: Can access internet with router but not with PC

Ive been using this modem with a home netgear wireless router and it worked just fine.  Pretty much plug and play.  Didnt have to touch anything on the modem for that to work.   I dont understand why it would be different with this router(1921).   I can try that if you think it will work.  Should I get a different modem to make this work??   Really trying to learn on the cisco devices.

Highlighted
VIP Mentor

Re: Can access internet with router but not with PC

Hello

no ip route 0.0.0.0 0.0.0.0 192.168.100.1
no access-list 1 permit any
no ip nat source list 1 interface GigabitEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 gig0/0 dhcp
access-list 1 permit 192.168.1.0
ip nat inside source list 1 interface GigabitEthernet0/0 overload

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: Can access internet with router but not with PC

Did what you said and still cannot ping google from my pc.  Can still ping google from router and can ping router from pc.  

Highlighted
VIP Mentor

Re: Can access internet with router but not with PC

Hello

sh ip nat translations
sh ip route

On client
ipconfig /all



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: Can access internet with router but not with PC

Router

Router#sh ip nat tra
Router#sh ip nat translations

Router#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 73.21.25.1 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 73.21.25.1, GigabitEthernet0/0
73.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 73.21.25.0/24 is directly connected, GigabitEthernet0/0
L 73.21.25.220/32 is directly connected, GigabitEthernet0/0
76.0.0.0/32 is subnetted, 1 subnets
S 76.96.93.25 [254/0] via 73.21.25.1, GigabitEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet0/1
L 192.168.1.1/32 is directly connected, GigabitEthernet0/1
Router#

 

Client

Ethernet adapter Ethernet 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I218-V
Physical Address. . . . . . . . . : 78-24-AF-D9-F0-1A
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::f5a7:b5ad:f29:29d0%15(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.61(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, July 30, 2020 4:46:16 PM
Lease Expires . . . . . . . . . . : Friday, July 31, 2020 4:46:16 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 125314223
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-25-97-22-3E-78-24-AF-D9-F0-1A
DNS Servers . . . . . . . . . . . : 4.2.2.2
4.2.2.1
8.8.8.8
8.8.4.4
NetBIOS over Tcpip. . . . . . . . : Enabled

C:\Users\thego>ping google.com
Ping request could not find host google.com. Please check the name and try again.

C:\Users\thego>ping 192.168.100.1

Pinging 192.168.100.1 with 32 bytes of data:
Reply from 192.168.100.1: bytes=32 time<1ms TTL=63
Reply from 192.168.100.1: bytes=32 time=1ms TTL=63
Reply from 192.168.100.1: bytes=32 time<1ms TTL=63
Reply from 192.168.100.1: bytes=32 time=1ms TTL=63

Ping statistics for 192.168.100.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\Users\thego>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.1: bytes=32 time<1ms TTL=255
Reply from 192.168.1.1: bytes=32 time<1ms TTL=255
Reply from 192.168.1.1: bytes=32 time<1ms TTL=255
Reply from 192.168.1.1: bytes=32 time<1ms TTL=255

Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\thego>

Highlighted
VIP Mentor

Re: Can access internet with router but not with PC

Hello

Whats interesting is your wan ip address is an actual pubic routed ip and not a private address which suggests your modem isnt performing any Nat on your behalf and that the old wifi router you had connected most probably.

From client trying pinging google via ip address not fqdn
ping 8.8.8.8 or 8.8.4.4

 

Lasty - Would you be able to obtain the mac-address of off the interface of the wifi router that was connected to the modem?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: Can access internet with router but not with PC

Thank you for the response.  

 

This is what i get when i ping from client.  Full success when i ping these from router btw.

 

Ethernet adapter Ethernet 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I218-V
Physical Address. . . . . . . . . : 78-24-AF-D9-F0-1A
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::f5a7:b5ad:f29:29d0%15(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.61(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, July 30, 2020 7:40:25 PM
Lease Expires . . . . . . . . . . : Friday, July 31, 2020 7:40:25 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 125314223
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-25-97-22-3E-78-24-AF-D9-F0-1A
DNS Servers . . . . . . . . . . . : 4.2.2.2
4.2.2.1
8.8.8.8
8.8.4.4
NetBIOS over Tcpip. . . . . . . . : Enabled

C:\Users\thego>ping 8.8.8.8

Pinging 8.8.8.8 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 8.8.8.8:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\thego>ping 8.8.4.4

Pinging 8.8.4.4 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 8.8.4.4:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\thego>

 

 

This is the MAC address from my old netgear wireless router that worked fine with this modem.

20:E5:2A:52:DF:D0

 

Let me know your thoughts