cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
994
Views
4
Helpful
3
Replies
pankaj.bandewar
Beginner

Can PBR and route map work on IPBase image 3850 and Whether PBR is correctly configured by me ?

Hello experts,

Kindly suggest me the configuration change required or if wrong any.

Scenario: I want Wired users to go to HQ from MPLS line 1 and Wireless Users to go via MPLS line 2 and when one of them were not available it should fall back to available link.

Here is snippet :

Please find attached Image for scenario.

ip route 0.0.0.0 0.0.0.0 10.106.72.210
ip route 0.0.0.0 0.0.0.0 ????
!
track 50 ip sla 1 reachability
!
track 100 ip sla 2 reachability
!
ip access-list extended Wired_Users
permit ip 10.106.92.0 0.0.0.255 any log
ip access-list extended Wireless_Users
permit ip 10.106.93.0 0.0.0.255 any log
!
ip sla 1
icmp-echo ????
frequency 5
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 10.106.72.209
frequency 5
ip sla schedule 2 life forever start-time now
!
route-map PBR_Wireless_Users permit 10
match ip address Wireless_Users
set ip next-hop verify-availability ????? 10 track 50
!
route-map PBR_Wired_Users permit 10
match ip address Wired_Users
set ip next-hop verify-availability 10.106.72.209 10 track 100
!
interface Vlan2
description "Wired-PC"
ip address 10.106.92.1 255.255.255.0
ip helper-address 10.106.75.21
ip policy route-map PBR_Wired_Users
!
interface Vlan3
description "Wireless"
ip address 10.106.93.1 255.255.255.0
ip helper-address 10.106.75.21
ip policy route-map PBR_Wireless_Users
!

 

3 REPLIES 3
Piyush Jain
Beginner

Hi Ranjan,

I think below URL can answer your query.

https://supportforums.cisco.com/blog/149901/pbr-switches-37503560 

paul driver
VIP Mentor

Hello

Looks like you can but need to change the SDM template

C3850

You can also trim your config down a little as you only will need to PBR on the Wireless users as they will not be using the default route

Also suggest to set the default route to a conditional default so when it connect is lost it will be removed for the rip and allow the secondary to be used.

Example:
ip route 0.0.0.0 0.0.0.0 10.106.72.209 track 1   <---this is your conditional default route
ip route 0.0.0.0 0.0.0.0 10.106.73.209 200     <---this is you secondary default with admin distance of 200

ip sla 1
icmp-echo 10.106.72.209 source-ip 10.106.72.210
frequency 5
ip sla schedule 1 life forever start-time now


ip sla 2
icmp-echo 10.106.73.209 source-ip 10.106.73.210
frequency 5
ip sla schedule 2 life forever start-time now

track 1 ip sla 1 reachability <----------For conditional route
track 100 ip sla 2 reachability <----------For PBR


ip access-list extended Wireless_Users
permit ip 10.106.93.0 0.0.0.255 any log

route-map PBR_Wireless_Users permit 10
match ip address Wireless_Users
set ip next-hop verify-availability 10.106.73.209 1 track 100

interface Vlan3
description "Wireless"
ip address 10.106.93.1 255.255.255.0
ip helper-address 10.106.75.21
ip policy route-map PBR_Wireless_Users


res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Sir Thank you very much for the detailed explanation ..i will be applying the configuration, once done i will confirm you the same.