cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
460
Views
15
Helpful
7
Replies
Highlighted

can't access the network via cisco router 2611xm config with a pppoe

Hello guys,

I'm Ben, I came to you guys with hope of helping me with a sort of problem that probably no one had. 

So let's dive in the problem.

 

I have a pppoe connection from my ISP and I set up it on my cisco router with the account password and other things I need it, utill now everything was good. The problem stats after I set up on my laptop a ip, net mask, gateway, dns. I can't browse it on the net but I can ping any ip or domain (from the router and just ips form laptop), with my DNS that was provide it to me from my ISP but with an open dns llike 8.8.8.8 and 8.8.4.4 I can go on the internet.

 

summary: with my dns from isp can go on internet just ping, but with open dns from google I can

 

Can someone help me I try to find a solution for days.

 

Thank you in advance

 

I have a cisco router 2611xm with following config

 

Current configuration : 2177 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname R1-ALFA

!

boot-start-marker

boot-end-marker

!

security passwords min-length 10

enable secret 5 ***********************

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

ip domain name domain.ro 

ip name-server 213.156.124.1

ip name-server 193.231.255.1

login block-for 180 attempts 3 within 180

!

multilink bundle-name authenticated

!

!

!

!

!

username ******* password 7 **********

archive

 log config

  hidekeys

!

!

!

!

interface FastEthernet0/0

 description The interface that talk with ISP

 no ip address

 duplex auto

 ip nat outside

 speed auto

 pppoe enable group global

 pppoe-client dial-pool-number 12

 no cdp enable

!

interface FastEthernet0/1

 description The interface that let you to play inside

 ip address 172.16.30.161 255.255.255.240

 ip nat inside

 ip virtual-reassembly

 no ip mroute-cache

 duplex auto

 speed auto

 no cdp enable

 no mop enabled

!

interface Dialer12

 ip address negotiated

 no ip redirects

 no ip unreachables

 ip mtu 1492

 ip nat outside

 ip virtual-reassembly

 encapsulation ppp

 ip tcp adjust-mss 1452

 no ip mroute-cache

 dialer pool 12

 dialer idle-timeout 0

 dialer persistent

 dialer-group 12

 no cdp enable

 ppp authentication pap callin

 ppp pap sent-username ********** password 7 ***********

 ppp ipcp dns request

 ppp ipcp route default

 ppp ipcp address accept

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

ip dns server

ip nat inside source list 15 interface Dialer12 overload

!

access-list 15 permit 172.16.30.160 0.0.0.15

dialer-list 12 protocol ip permit

no cdp run

!

!

!

!

control-plane

!

!

banner motd ^CIf you're not the Admin get out!!^C

!

line con 0

 exec-timeout 180 0

 login local

line aux 0

line vty 0 4

 login local

line vty 5 15

 login local

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Hello
These two commands below should help any internal client dns request originating from this router to service dns.
ppp ipcp dns request  < -- obtain public dns from ISP
ip dns server < acts like a proxy dns server for client

What you are doing at the moment is manually bypassing using your own ISPs dns server and that's why it works using google DNS, For it to work using your own rtrs ISPs DNS, set the clients dns server to point to the router, In your case the client dns server will be 172.16.30.161 then test again.

 

Edited- if you are going to create a dhcp pool for you clients as suggest by @Georg Pauwen  set the dns server to your own router, Would also say you don't need to specify a static default route as you are receiving one from the ISP already.


> ip dhcp pool LAN
--> network 172.16.30.160 255.255.255.240
--> default-router 172.16.30.161
--> dns-server 172.16.30.161



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

7 REPLIES 7
Highlighted
VIP Expert

Hello,

 

first of all, you have no default route. Add this to your configuration:

 

ip route 0.0.0.0 0.0.0.0 Dialer12

 

If this doesn't help, which DNS servers are you using ? The easiest would be to just use the router as DHCP server, with the configuration changes maked in bold:

 

Current configuration : 2177 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1-ALFA
!
boot-start-marker
boot-end-marker
!
security passwords min-length 10
enable secret 5 ***********************
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
ip domain name domain.ro
--> no ip name-server 213.156.124.1
--> no ip name-server 193.231.255.1
login block-for 180 attempts 3 within 180
!
--> ip dhcp excluded-address 172.16.30.161
!
--> ip dhcp pool LAN
--> network 172.16.30.160 255.255.255.240
--> default-router 172.16.30.161
--> dns-server 8.8.8.8 8.8.4.4
!
multilink bundle-name authenticated
!
username ******* password 7 **********
archive
log config
hidekeys
!
interface FastEthernet0/0
description The interface that talk with ISP
no ip address
duplex auto
ip nat outside
speed auto
pppoe enable group global
pppoe-client dial-pool-number 12
no cdp enable
!
interface FastEthernet0/1
description The interface that let you to play inside
ip address 172.16.30.161 255.255.255.240
ip nat inside
ip virtual-reassembly
no ip mroute-cache
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface Dialer12
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 12
dialer idle-timeout 0
dialer persistent
dialer-group 12
no cdp enable
ppp authentication pap callin
ppp pap sent-username ********** password 7 ***********
ppp ipcp dns request
ppp ipcp route default
ppp ipcp address accept
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
ip dns server
!
--> ip route 0.0.0.0 0.0.0.0 Dialer 12
!
ip nat inside source list 15 interface Dialer12 overload
!
access-list 15 permit 172.16.30.160 0.0.0.15
dialer-list 12 protocol ip permit
no cdp run
!
control-plane
!
banner motd ^CIf you're not the Admin get out!!^C
!
line con 0
exec-timeout 180 0
login local
line aux 0
line vty 0 4
login local
line vty 5 15
login local
!
end

Highlighted

Hello @Georg Pauwen 
adding a static default isn't require as the router accepting the ISPs -  ppp ipcp route default



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

ciao,

 

I tried what you said, without result, but what said @paul driver it work

Highlighted

Thank you for you time and help 

Highlighted
VIP Mentor

Hello
These two commands below should help any internal client dns request originating from this router to service dns.
ppp ipcp dns request  < -- obtain public dns from ISP
ip dns server < acts like a proxy dns server for client

What you are doing at the moment is manually bypassing using your own ISPs dns server and that's why it works using google DNS, For it to work using your own rtrs ISPs DNS, set the clients dns server to point to the router, In your case the client dns server will be 172.16.30.161 then test again.

 

Edited- if you are going to create a dhcp pool for you clients as suggest by @Georg Pauwen  set the dns server to your own router, Would also say you don't need to specify a static default route as you are receiving one from the ISP already.


> ip dhcp pool LAN
--> network 172.16.30.160 255.255.255.240
--> default-router 172.16.30.161
--> dns-server 172.16.30.161



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

Highlighted

ola,

 

I set the dns from dhcp to my default-gateway and now is works fine.

 

Now I have other question "why now is working :))))))"

 

With the config 

ip dhcp pool IntraNet-LAN
network 172.16.30.160 255.255.255.240
default-router 172.16.30.161
dns-server 172.16.30.161
lease infinite

is ok

Highlighted

Hello

i have already explained why,



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future