cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
200
Views
0
Helpful
2
Replies
Highlighted

Can't redistribute the static routes from an OSPF stub area into backbone area - Nexus

image.png

I try with this configuration, it's not work.

N9K1# sho ip rou static
x.151.177.0/25, ubest/mbest: 1/0
    *via x.151.177.200, [1/0], 00:31:53, static
     via Null0, [191/0], 00:31:53, static
x.151.178.0/24, ubest/mbest: 1/0
    *via x.151.177.200, [1/0], 00:15:29, static

ip access-list GACL
  10 permit ip x.151.177.0/25 any
  20 permit ip x.151.178.0/24 any

ip prefix-list Gprefix seq 10 permit x.151.177.0/25
ip prefix-list Gprefix seq 20 permit x.151.178.0/24

route-map Groute-map permit 5
  match ip address GACL
route-map Groute-map permit 10
  match ip address prefix-list Gprefix

router ospf 100
  area 0.0.0.40 stub
  redistribute static route-map Groute-map
  passive-interface default

How should I do?

Thank you very much.

2 REPLIES 2
Highlighted
Beginner

you will have to convert your area to NSSA if you want to redistribute something. Stub areas does not allow LSA type 4-5

Highlighted
Hall of Fame Master

Hello @ปลาวาฬทราย RMUTT CPE IX ,

change OSPF area 0.0.0.40 type from stub area to NSSA.

This is the only way to support an ASBR = a redistribution into area 0.0.0.40 while at the same time avoiding to receive all the external routes that are in the backbone.

 

An ASBR cannot exist in a stub or totally stub area. NSSA uses LSA type 7 to generate special type external routes that are converted to conventional LSA type 5 by ABR (0.0.0.0, 0.0.0.40)

 

The change has to be done on all the routers in the area, as an alternative create a new NSSA area with ABR nodes and the desired ASBR node(s).

 

Hope to help

Giuseppe