12-03-2015 05:12 AM - edited 03-05-2019 02:51 AM
Hi Everyone, I'm hoping someone can me to see what I'm doing wrong here.
I have to routers R1 and R2 which are connected to geather with a serial cable. R1 has access to internet and I'm trying to get R2 to access the internet as well with no luck. Here is my config for R1 and R2.
Router 1
interface GigabitEthernet0/0
description LAN
ip address 10.1.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet0/1
description WAN
ip address 192.168.1.33 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.75.1 255.255.255.0
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 192.168.75.0 0.0.0.255 area 0
network 10.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
Router 2 Config.
interface GigabitEthernet0/0
description LAN
ip address 10.1.2.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.75.2 255.255.255.0
!
!
router ospf 1
log-adjacency-changes
network 192.168.75.0 0.0.0.255 area 0
network 10.1.2.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.75.1
!
ip flow-export version 9
Any suggestion and help is highly appreciated.
Regards,
Theo.
Solved! Go to Solution.
12-03-2015 05:47 AM
Hello,
You have configured NAT, but it is not complete.
Add this configuration on R1
access-list 50 permit 10.1.2.0 0.0.0.255
Ip nat inside source list 50 interface GigabitEthernet0/1 overload.
interface Serial0/0/0
ip nat inside.
Let me know your feedback,
Masoud
12-03-2015 05:20 AM
Just to add on, I can ping 192.168.1.33 (WAN interface on R1) from R2. This is as far as I can go.
Thank you.
12-03-2015 05:47 AM
Hello,
You have configured NAT, but it is not complete.
Add this configuration on R1
access-list 50 permit 10.1.2.0 0.0.0.255
Ip nat inside source list 50 interface GigabitEthernet0/1 overload.
interface Serial0/0/0
ip nat inside.
Let me know your feedback,
Masoud
12-03-2015 06:29 AM
Thank you Kindly Masoud,
I can now access the internet from R2. Amazing :)
Cheers.
Theo.
12-03-2015 06:36 AM
You are welcome. I am glad your problem was solved.
Masoud
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide