03-04-2023
04:10 PM
- last edited on
03-07-2023
09:11 PM
by
Translator
Greetings,
I am studying for my CCNA and got a few routers and switches for a test lab. I am just trying to get 2 Cisco 2800 routers to communicate properly and I am running into problems. I tried first with the serial ports, and now I am trying with Ethernet, but still can't seem to get it. This same configuration works on packet tracer; R1 has internet connectivity, but R2 does not. Can someone please help to point me in the right direction? Thanks in advance for even looking at my request.
My cable modem with builtin router is 10.0.0.0/24.
Port 1 of the cable modem's switch is connected to Gi0/0 on R1 with ip address 10.0.0.40/24
Port Gi0/1 of R1 has ip address 10.1.0.1/24 and is connected to port Gi0/0 on R2 which has ip address 10.1.0.2/24
Port Gi0/0 of R2 has ip address 10.1.1.1/24 and is connected to a Cisco 2960 switch with no configuration (write erase).
R1 can ping 8.8.8.8
R2 can ping 10.1.0.1 and 10.0.0.40, but cannot ping 10.0.0.1 or 8.8.8.8.
R1 configuration
-----------------------------------------
R1#show running-config
Building configuration...
Current configuration : 922 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
dot11 syslog
!
ip cef
!
multilink bundle-name authenticated
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
interface GigabitEthernet0/0
ip address 10.0.0.40 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.1.0.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/3/0
no ip address
shutdown
no fair-queue
!
interface Serial0/3/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
R1#
-----------------------------------------
R2 Configuration
-----------------------------------------
R2#show running-config
Building configuration...
Current configuration : 1154 bytes
!
! Last configuration change at 02:21:20 UTC Sun Mar 5 2023
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service password-recovery
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
dot11 syslog
ip source-route
!
ip cef
!
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
!
license udi pid CISCO2821 sn FTX1107A54P
!
redundancy
!
interface GigabitEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.1.0.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/3/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/3/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.1.0.1
!
control-plane
!
mgcp profile default
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end
R2#
-----------------------------------------
Matthew
"When you teach someone what you know, you gain a greater understanding of the subject, which increases your own retention of the knowledge."
Solved! Go to Solution.
03-05-2023
01:23 AM
- last edited on
03-07-2023
09:14 PM
by
Translator
Hello,
just to make sure you understand what is needed, and what @Harold Ritter and @Kasun Bandara correctly suggest, make the changes marked in bold on R1:
R1
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
dot11 syslog
!
ip cef
!
multilink bundle-name authenticated
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
interface GigabitEthernet0/0
ip address 10.0.0.40 255.255.255.0
--> ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.1.0.1 255.255.255.0
--> ip nat inside
duplex auto
speed auto
!
interface Serial0/3/0
no ip address
shutdown
no fair-queue
!
interface Serial0/3/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
--> ip nat inside source list 1 interface GigabitEthernet0/0 overload
!
--> ip route 10.1.1.0 255.255.255.0 10.1.0.2
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
--> access-list 1 permit 10.1.1.0 0.0.0.255
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
03-04-2023
06:13 PM
- last edited on
03-07-2023
09:13 PM
by
Translator
hi, you need to configure
NAT in R1 and return route to 10.1.1.1 255.255.255.0 in R1
03-04-2023
06:31 PM
- last edited on
03-07-2023
09:13 PM
by
Translator
Hi @Kasun Bandara ,
Both NAT and static route to 10.1.1.0/24 are required on R1.
Regards,
03-05-2023
01:23 AM
- last edited on
03-07-2023
09:14 PM
by
Translator
Hello,
just to make sure you understand what is needed, and what @Harold Ritter and @Kasun Bandara correctly suggest, make the changes marked in bold on R1:
R1
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
dot11 syslog
!
ip cef
!
multilink bundle-name authenticated
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
interface GigabitEthernet0/0
ip address 10.0.0.40 255.255.255.0
--> ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.1.0.1 255.255.255.0
--> ip nat inside
duplex auto
speed auto
!
interface Serial0/3/0
no ip address
shutdown
no fair-queue
!
interface Serial0/3/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
--> ip nat inside source list 1 interface GigabitEthernet0/0 overload
!
--> ip route 10.1.1.0 255.255.255.0 10.1.0.2
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
--> access-list 1 permit 10.1.1.0 0.0.0.255
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
03-07-2023 06:51 PM
Thanks Georg for your thorough response. I also found a video on YouTube by "itsupportpeople219" that explained how to connect a router to a home network. The video covered a bunch that I did already know, but I figured I would mention it in case anyone else lands here looking for help and needs a step by step tutorial.
I also appreciate the responses by Harold and Kasun which both aimed to steer me in the right direction.
Thank you all!
Matthew
"When you teach someone what you know, you gain a greater understanding of the subject, which increases your own retention of the knowledge."
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide