08-31-2019 12:59 PM
Hy guys,
I have a question that has been bugging me for some time now
I have an CISCO router 1841 with 2 interfaces F0/1 and F0/0 and for testing purposes i have it in my LAN at home. The problem is though, in Packet Tracer I create 4 LANs all wired together with the 4 routers(1841) and i get to ping from one end to another . I configure the interfaces and all is good. However when I physically connect my 1841 router in my LAN , I cannot get past the router.
The layout is like this:
1. My TP LINK router that is directlly connected to the internet and acts as a DNS server and GATEWAY
2. The CISCO router in between the PC and the GATEWAY connected to F0/1 (192.168.1.x/24 NETWORK)
3. The PC that I use for daily tasks that is directlly connected to the F0/0 (10.90.0.X/24 NETWORK) of the router
Now, the problem I have is this:
From the PC I can ping F0/0 of the router and even F0/1 , but when I try to go beyond the router (to my GATEWAY) I get no reply back.
I have no ACL set in place on the router . The only thing I configured is the IP, MASK. I have tryed with static routes, default routes,( which I dont see the point because the router is directlly connected to both networks and should be aware of both - but I tryed that anyway) and still I get no reply back from the GATEWAY.
So my question is this
Does the 1841 router treats F0/0 as the WAN link and F0/1 as the LAN link as it is in the normal TPLINK home router and this is why the traffic cannot get past the router?
Solved! Go to Solution.
09-04-2019 01:25 PM
Make the following changes (marked in bold) to your configuration:
interface FastEthernet0/0
--> no mac-address x.x.x
ip address 94.x.x.x 255.255.255.240
ip nat outside
--> no ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
ip nat inside
--> no ip virtual-reassembly
duplex auto
speed auto
!
--> no ip default-gateway 94.x.x.x
ip forward-protocol nd
--> no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 94.x.x.x
!
ip http server
no ip http secure-server
ip dns server
!
--> no ip nat pool silviu 94.x.x.x 94.x.x.x netmask 255.255.255.240
ip nat inside source list 1 interface FastEthernet0/0
!
access-list 1 permit 192.168.0.0 0.0.0.255
08-31-2019 01:54 PM
You ask this question "Does the 1841 router treats F0/0 as the WAN link and F0/1 as the LAN link " The answer is that no the 1841 router does not necessarily treat any interface particularly as WAN or as LAN. The decision about which interface is WAN and which interface is LAN depends on the IP addresses assigned and the routing configured.
We do not have much detail to work with about this issue. Based on the little that we do know I would guess that the issue is that your Gateway does not know about the 10.90.0.0 network. One potential solution to this would be to configure the Gateway with a route for the 10.90.0.0 network.
But that might not be the best solution. For your PC to access the Internet its private address would need to be translated to some public address. One option might be to configure your Gateway to translate the 10.90.0.0 network. But the other solution might be for you to configure address translation on the 1841 so that packets from the PC arrive at the Gateway with an address in 192.168.1.0.
HTH
Rick
09-04-2019 12:30 PM
Thanks for the replies.
I eventually managed to figure out why the packets didnt go back and the answer downed on me that my cheap home router didnt have a way to put a static route that would notify about the 10 network that sits after the 1841 router, and i am guessing that the home router (gateway in my lan) would send the packets to wan (actually internet link)
however i ran into another problem if anybody is inclined to help me
i removed my home router and i put my 1841 router in its place so the network configuration is like this
1841 - pc
that simple
on my 1841 router i have 2 interfaces
f0/0 - 94.x.x.x - this is my actual external internet ip address
f0/1 - 192.168.0.1
i erased the startup-config so i could start fresh
and the only thing i configured is this
int f0/0 94.x.x.x 255.255.255.240
mac-address x.x.x.x
no shut
int f0/1 192.168.0.1 255.255.255.0
no shut
ip nat pool silviu 94.x.x.x 94.x.x.x(same IP) netmask 255.255.255.240
ip nat inside source list 1 pool silviu overload
int f0/1
ip nat inside
intf0/0
ip nat outside
access-list 1 permit 192.168.0.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 94.X.X.X
ip name-server MYDNSSERVER
I configured my pc
192.168.0.2
255.255.255.0
gw 192.168.0.1
dns 192.168.0.1
and it works , believe it or not, i get connectivity from my PC, I can get to the internet and so on
however
with my home router i get normal speed 10MB /s
with 1841 router i get 10KB /s maximum, and not to mention that there are times when it does not work
so the question i am asking is this
could this be a faulty router ? ( i have bought it for testing purposes for my CCNA exam, used from a dealer)
or am I doing something wrong?
09-04-2019 12:40 PM
Hello,
10Kbps could be an MTU issue. Can you post the full running config (show run) of the router ?
09-04-2019 12:47 PM
how can i export it without having to type it manually?
09-04-2019 12:55 PM
Can't you just copy and paste from the command line ?
09-04-2019 12:56 PM
Router#sh run
Building configuration...
Current configuration : 1235 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$OHrS$I8QphSx1bvV0qCqaM4AJY1
!
no aaa new-model
dot11 syslog
ip cef
!
!
!
!
ip name-server 188.x.x.x
ip name-server 94.x.x.x
!
multilink bundle-name authenticated
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
interface FastEthernet0/0
mac-address x.x.x
ip address 94.x.x.x 255.255.255.240
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip default-gateway 94.x.x.x
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 94.x.x.x
!
!
ip http server
no ip http secure-server
ip dns server
ip nat pool silviu 94.x.x.x 94.x.x.x netmask 255.255.255.240
ip nat inside source list 1 pool silviu overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0
password silviu
login
line vty 1 4
login
!
scheduler allocate 20000 1000
end
Router#
09-04-2019 01:25 PM
Make the following changes (marked in bold) to your configuration:
interface FastEthernet0/0
--> no mac-address x.x.x
ip address 94.x.x.x 255.255.255.240
ip nat outside
--> no ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
ip nat inside
--> no ip virtual-reassembly
duplex auto
speed auto
!
--> no ip default-gateway 94.x.x.x
ip forward-protocol nd
--> no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 94.x.x.x
!
ip http server
no ip http secure-server
ip dns server
!
--> no ip nat pool silviu 94.x.x.x 94.x.x.x netmask 255.255.255.240
ip nat inside source list 1 interface FastEthernet0/0
!
access-list 1 permit 192.168.0.0 0.0.0.255
09-04-2019 01:43 PM
09-04-2019 01:57 PM
Just the first...try the NAT without a NAT pool...
09-04-2019 01:59 PM
so, in a nut shell, it worked :)
could have been the mac-address comand or ip virtual reassembly that was causing the router to slow down?
anyway , thank you for your advice and your time
cheers
09-04-2019 02:02 PM
The virtual reassembly enabled could really slow everything down, so that was most likely the underlying problem...
09-04-2019 02:04 PM
it was on by default , i didn't put it here.
is it a good practice, when configuring a cisco router to disable it?
09-04-2019 02:12 PM
Hello,
I think it is enabled by default when you configure 'ip nat inside'. Actually, what happens if you turn it back on ? There were some other things in your configuration that could have caused the slowness...
09-04-2019 02:27 PM
so, i turned
ip virtual-reassembly
on
and i still get the same speed 10MB /s which is great so I am thinking that the slowness came from mac-address, which btw it took me 30 minuets to figure out that cisco router interface will stop working if detects 2 same mac addreses :) on the same lan , or so it was in my case
anyway
thank you again
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide