10-02-2013 04:03 AM - edited 03-04-2019 09:12 PM
HI,
i am trying to configeure a cisco 1921 router with adsl and load balancing. i am not to sure if the config i have done will work. at the moment the lines are both fault.
here is the config that i have done so far.
AIDC01R#sho run
Building configuration...
Current configuration : 3431 bytes
!
! Last configuration change at 14:57:05 UTC Tue Oct 1 2013 by mars
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AIDC01R
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 iUu5KFbyns7bMwYiStzvHwru7Xj7ZwnUe3UawdnCQR2
!
no aaa new-model
!
ip cef
ip routing
!
!
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FCZ173692E1
!
!
username mars password 7 00291214174F0E050770
!
redundancy
!
!
!
!
!
controller VDSL 0/0/0
!
controller VDSL 0/1/0
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
description Vlan 10 - Management
encapsulation dot1Q 10
ip address 192.168.121.1 255.255.255.192
ip nat inside
!
interface GigabitEthernet0/0.20
description Vlan 20 - Servers
encapsulation dot1Q 20
ip address 192.168.121.65 255.255.255.192
ip nat inside
!
interface GigabitEthernet0/0.30
description Vlan 30 - Admin
encapsulation dot1Q 30
ip address 192.168.121.129 255.255.255.192
ip helper-address 192.168.121.66
ip nat inside
!
interface GigabitEthernet0/0.40
description Vlan 40 - Guests
encapsulation dot1Q 40
ip address 192.168.121.193 255.255.255.192
ip helper-address 192.168.121.66
ip nat inside
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface ATM0/0/0
description connection to telkom
no ip address
no atm ilmi-keepalive
no shut
!
interface ATM0/0/0.35 point-to-point
description telkom adsl
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface Ethernet0/0/0
no ip address
shutdown
!
interface ATM0/1/0
description connection to telkom
no ip address
no shutdown
no atm ilmi-keepalive
!
interface ATM0/1/0.35 point-to-point
description telkom adsl
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface Ethernet0/1/0
no ip address
shutdown
!
interface Dialer0
ip address negotiated
no ip redirects
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname *****************************
ppp chap password 7 *************************
ppp pap sent-username *********************** password 7 *************************
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
description To Telkom ADSL 1
ip address negotiated
no ip redirects
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname *****************************
ppp chap password 7 *************************
ppp pap sent-username *********************** password 7 *************************
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
interface Dialer1
description To Telkom ADSL 2
ip address negotiated
no ip redirects
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname vnaidooaidc@telkomsa.net
ppp chap password 7 097C5A011E111A5C5E
ppp pap sent-username vnaidooaidc@telkomsa.net password 7 081158460E0D085947
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list standard NAT
permit 192.168.121.0 0.0.0.255
!
ip nat inside source list NAT interface dialer0 overload
ip nat inside source list NAT interface dialer1 overload
!
control-plane
!
!
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input all
!
scheduler allocate 20000 1000
!
end
can any body please help
10-02-2013 04:28 AM
Hi,
if you want to do NAT overload over 2 WAN links your config should look like this:
ip access-list standard NAT
permit 192.168.121.0 0.0.0.255
route-map DIAL0
match ip add NAT
match interface dialer0
route-map DIAL1
match ip add NAT
match interface dialer1
no ip nat inside source list NAT interface dialer0 overload
no ip nat inside source list NAT interface dialer1 overload
ip nat inside source route-map DIAL0 interface dialer0
ip nat inside source route-map DIAL1 interface dialer1
Also provide output from following:
-sh ip int br | exc una
-sh ip route static
Regards
Alain
Don't forget to rate helpful posts.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide