cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
864
Views
5
Helpful
3
Replies

Cisco 1941 - PPOE / MTU / Fragmentation Issue

bytewize_ns
Level 1
Level 1

Hoing someone can see what is going on here..

 

I have a clients site that io have configured a layer 3 FTTP NBN connection, the ISP only support PPOE and no EoIP, I have set the virtual interface Dialer1 and configured everything as far as i'm aware it seems correct the link is up and the site is functional but I am experiencing fragmentation issues and inconsistent speeds and latency due to the misconfiguration somewhere.. 

 

Here is the config:

 

interface GigabitEthernet0/0
description Primary Physical LAN Interface
no ip address
ip virtual-reassembly in
duplex full
speed 1000
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
description Primary LAN Interface
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Dialer1
description Primary Virtual WAN Interface
mtu 1492
ip address negotiated
ip access-group 100 in
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname xxxxx
ppp chap password 0 xxxx
ppp pap sent-username xxxx password 0 xxxx
no cdp enable

!

 

------

When i run sh ip traffic:

IP statistics:
Rcvd: 39370 total, 37530 local destination
0 format errors, 0 checksum errors, 0 bad hop count
0 unknown protocol, 0 not a gateway
0 security failures, 0 bad options, 0 with options
Opts: 0 end, 0 nop, 0 basic security, 0 loose source route
0 timestamp, 0 extended security, 0 record route
0 stream ID, 0 strict source route, 0 alert, 0 cipso, 0 ump
0 other
Frags: 0 reassembled, 0 timeouts, 0 couldn't reassemble
25 fragmented, 110 fragments, 2 couldn't fragment
0 invalid hole
Bcast: 2696 received, 0 sent

 

When i run 

rre-rt001#sh ip virtual-reassembly
GigabitEthernet0/0:
Virtual Fragment Reassembly (VFR) is ENABLED [in]
Concurrent reassemblies (max-reassemblies): 16
Fragments per reassembly (max-fragments): 32
Reassembly timeout (timeout): 3 seconds
Drop fragments: OFF

Current reassembly count:0
Current fragment count:0
Total reassembly count:0
Total reassembly timeout count:0

GigabitEthernet0/1:
Virtual Fragment Reassembly (VFR) is ENABLED [in]
Concurrent reassemblies (max-reassemblies): 16
Fragments per reassembly (max-fragments): 32
Reassembly timeout (timeout): 3 seconds
Drop fragments: OFF

Current reassembly count:0
Current fragment count:0
Total reassembly count:1
Total reassembly timeout count:0

Cellular0/0/0:
Virtual Fragment Reassembly (VFR) is ENABLED [in]
Concurrent reassemblies (max-reassemblies): 16
Fragments per reassembly (max-fragments): 32
Reassembly timeout (timeout): 3 seconds
Drop fragments: OFF

Current reassembly count:0
Current fragment count:0
Total reassembly count:0
Total reassembly timeout count:0

Dialer1:
Virtual Fragment Reassembly (VFR) is ENABLED [in]
Concurrent reassemblies (max-reassemblies): 16
Fragments per reassembly (max-fragments): 32
Reassembly timeout (timeout): 3 seconds
Drop fragments: OFF

Current reassembly count:0
Current fragment count:0
Total reassembly count:15107
Total reassembly timeout count:1


Mcast: 0 received, 0 sent
Sent: 45973 generated, 2369946 forwarded
Drop: 0 encapsulation failed, 0 unresolved, 0 no adjacency
0 no route, 0 unicast RPF, 0 forced drop
0 options denied
Drop: 0 packets with source IP address zero
Drop: 0 packets with internal loop back IP address
0 physical broadcast
Reinj: 0 in input feature path, 0 in output feature path

 

***

 

I contacted the ISP NOC and they said my config should work and they sent me the config from their side as well.

 

interface Dialer1
ip address negotiated
ip virtual-reassembly in max-reassemblies 512
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp chap hostname xxxxxxxxxxxx
ppp chap password xxxxxxxxxxxx
ppp ipcp header-compression ack
ppp ipcp dns request accept
ppp ipcp address required
end
#
interface GigabitEthernet0/1
description WAN
no ip address
ip flow ingress
ip flow egress
ip virtual-reassembly in
ip tcp adjust-mss 1452
pppoe enable group global
pppoe-client dial-pool-number 1
end
------------------

 

I have tried setting the ports to auto and manual on g0/0

I have tried setting ip tcp adjust-mss 1452 on both interfaces and also only on the internal 

 

When i ping from the LAN side to test packet size I get:

 

C:\Users\administrator.CORP>ping 8.8.8.8 -f -l 1464

Pinging 8.8.8.8 with 1464 bytes of data:
Reply from 8.8.8.8: bytes=1464 time=23ms TTL=122
Reply from 8.8.8.8: bytes=1464 time=23ms TTL=122
Reply from 8.8.8.8: bytes=1464 time=23ms TTL=122
Reply from 8.8.8.8: bytes=1464 time=24ms TTL=122

Ping statistics for 8.8.8.8:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 23ms, Maximum = 24ms, Average = 23ms

 

C:\Users\administrator.CORP>ping 8.8.8.8 -f -l 1465

Pinging 8.8.8.8 with 1465 bytes of data:
Reply from 192.168.1.1: Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.

Ping statistics for 8.8.8.8:
Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),

C:\Users\administrator.CORP>

 

I have tried adding the exact same config as the ISP above and issue still persists..

 

 

Can someone please help me work out what i'm doing wrong..

 

Thanks..

 

Adrian 

1 Accepted Solution

Accepted Solutions

Hello,

 

based on your ping results, try the values below:

 

interface Dialer1
description Primary Virtual WAN Interface
mtu 1460
ip address negotiated
ip access-group 100 in
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1420
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname xxxxx
ppp chap password 0 xxxx
ppp pap sent-username xxxx password 0 xxxx
no cdp enable

View solution in original post

3 Replies 3

Hello,

 

based on your ping results, try the values below:

 

interface Dialer1
description Primary Virtual WAN Interface
mtu 1460
ip address negotiated
ip access-group 100 in
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1420
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname xxxxx
ppp chap password 0 xxxx
ppp pap sent-username xxxx password 0 xxxx
no cdp enable

Hi George,


Thanks for your reply, I tried this and still getting fragmentation.

 

I have my dialer interface set to:

 

interface Dialer1
description Primary Virtual WAN Interface
mtu 1460
ip address negotiated
ip access-group 100 in
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1420
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname XXX
ppp chap password 0 XXx
ppp pap sent-username XXX password 0 XXX
no cdp enable
end

 

I am now getting 

 

C:\Users\administrator.CORP>ping 8.8.8.8 -f -l 1433

Pinging 8.8.8.8 with 1433 bytes of data:
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.

Ping statistics for 8.8.8.8:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\administrator.CORP>ping 8.8.8.8 -f -l 1432

Pinging 8.8.8.8 with 1432 bytes of data:
Reply from 8.8.8.8: bytes=1432 time=23ms TTL=122
Reply from 8.8.8.8: bytes=1432 time=23ms TTL=122
Reply from 8.8.8.8: bytes=1432 time=23ms TTL=122
Reply from 8.8.8.8: bytes=1432 time=23ms TTL=122

Ping statistics for 8.8.8.8:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 23ms, Maximum = 23ms, Average = 23ms

 

--

 

The CPU usage is not maxing out.

 

I am blocking ICMP

 

access-list 100 deny icmp any any echo log

 

As the MSS clamping is set, should this matter? 

 

Thanks..

 

Adrian

@Georg Pauwen Thanks for confirming the correct config based on ICMP results. I worked the same answer out through calculation, in the end left my configuration in place and raised a ticket with the ISP to check their configuration. 

 

They never told me what the resolution was was but something was changed and all working smoothly now.

 

Review Cisco Networking products for a $25 gift card