cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

175
Views
0
Helpful
1
Replies
Beginner

Cisco 2921 Router- Help with Routing for multiple gig interfaces

Hi All,

I'm trying to relocate my lab rack to my basement, but want to keep one switch in my office.  I've got a 2921 router, a 3750 switch, and a basic managed netgear switch.  Everything is working fine, but I'm trying to duplicate the settings out of my router so both gig0/1 and gig0/2 do the exact same things.  Is that possible?  

 

Right now, gig 0/1 plugs into my cisco switch on 10.0.1.0/24 and it pipes the feed from my router upstairs to my office.  I'd like to enable gig0/2 to have the exact same ip addressing and route config as gig0/1 so that I can feed a small netgear switch in the basement, is that possible using the same 10.0.1.0/24 address scheme?  Here is my 2921 show run

 

Lab_2921#show run
Building configuration...


Current configuration : 2091 bytes
!
! Last configuration change at 12:35:23 EST Sat Apr 6 2019 by davidstriplin
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_2921
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$SsVR$V9SJLHz03PmbBnBTIG5t51
!
no aaa new-model
clock timezone EST -5 0
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.0.1.170
ip dhcp excluded-address 10.0.1.100 10.0.1.254
ip dhcp excluded-address 10.0.1.1
!
ip dhcp pool Inside DHCP
network 10.0.1.0 255.255.255.0
dns-server 75.75.75.75 75.75.76.76
default-router 10.0.1.1
!
!
ip dhcp class any
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1728AHR1
!
!
username davidstriplin secret 5 $1$zXDh$kKFRLQfASKutBCb7iYOMI1
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Facing The ISP (WAN)
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Facing The LAN (LAN)
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
description Secondary Feed to Basement
no ip address
ip nat inside
ip virtual-reassembly in
shutdown
duplex auto
speed auto
!
ip default-gateway 10.0.1.1
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp
ip ssh time-out 60
!
!
!
access-list 1 permit 10.0.1.0 0.0.0.255
access-list 102 permit ip 10.0.1.0 0.0.0.255 any
!
control-plane
!
!
vstack
!
line con 0
logout-warning 120
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password AlphaBravo9
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: Cisco 2921 Router- Help with Routing for multiple gig interfaces

Hello,

 

you can only assign the same IP address to two interfaces on your 2921 when one of the interfaces is shut. If both are active, you will get an error message...

 

It is not entirely clear, to me, what you want to accomplish...do you want traffic coming from the switch to be NATted out to the Internet ?

View solution in original post

1 REPLY 1
VIP Mentor

Re: Cisco 2921 Router- Help with Routing for multiple gig interfaces

Hello,

 

you can only assign the same IP address to two interfaces on your 2921 when one of the interfaces is shut. If both are active, you will get an error message...

 

It is not entirely clear, to me, what you want to accomplish...do you want traffic coming from the switch to be NATted out to the Internet ?

View solution in original post

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here