cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1000
Views
0
Helpful
3
Replies

Cisco 837 Routing issue?

jbryan189
Level 1
Level 1

I have a 837 that I'm getting setup for a charitable cause. I copied most of another operation setup but am having issues with the routing, I think.

THe ATM appears to be correct using the "ping atm interface 0 0 35 end-loopback" command.

I have pasted the run-config below:

   

version 12.3

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname Router

!

logging buffered 51200 debugging

no logging console

enable secret 5 $1$si4C$szqLUXsYOryuvNbl3Qnw2/

enable password 7 13151810595D53

!

no aaa new-model

ip subnet-zero

no ip source-route

no ip routing

ip tcp synwait-time 10

ip dhcp excluded-address 10.0.0.1 10.10.9.255

ip dhcp excluded-address 10.10.11.0 10.255.255.254

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool1

network 10.0.0.0 255.0.0.0

default-router 10.10.10.1

dns-server 8.8.8.8 8.8.4.4

!

!

no ip bootp server

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

!

interface Ethernet0

ip address 10.10.10.1 255.0.0.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

no ip route-cache

ip tcp adjust-mss 1412

hold-queue 100 out

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description $ES_WAN$

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

!

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname XXXX@XXXX.net

ppp chap password 7 1307050B0A02577B7C76

!

ip classless

ip route 0.0.0.0 0.0.0.0 ATM0

ip http server

ip http secure-server

!

logging trap debugging

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

no modem enable

line aux 0

line vty 0 4

password 7 12090A15435D55

login

!

scheduler max-task-time 5000

scheduler interval 500

!

end

              

As always thanks for the forums help!!! John

3 Replies 3

John Blakley
VIP Alumni
VIP Alumni

It looks like you're missing the "ip nat outside" command on the dialer interface.

Try this:

access-list 10 permit 10.0.0.0 0.255.255.255

ip nat inside source list 10 interface dial0 overload

int d0

ip nat outside

And you may need to change your default route to point to dialer0 instead of atm0...

There's some other documentation that I'm finding from Cisco that states to put the nat statement on the ATM interface though:

http://www.cisco.com/en/US/docs/routers/access/500/520/software/configuration/guide/520scg_ppp_atm_nat.html

HTH,

John

HTH, John *** Please rate all useful posts ***

Hi,

Routing is also disabled so you should enable it with the global config command: ip routing.

Regards.

Alain

Don't forget to rate helpful posts.

First, Thanks for the help!! New guy blues...

Looks right as best my untrained eyes can tell.

I am currently here, with not much success:

Current configuration : 2215 bytes

!

version 12.3

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname Router

!

logging buffered 51200 debugging

no logging console

enable secret 5 $1$si4C$szqLUXsYOryuvNbl3Qnw2/

enable password 7 13151810595D53

!

no aaa new-model

ip subnet-zero

no ip source-route

ip tcp synwait-time 10

ip name-server 64.250.192.64

ip name-server 64.250.192.65

ip dhcp excluded-address 10.0.0.1 10.10.9.255

ip dhcp excluded-address 10.10.11.0 10.255.255.254

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool1

   network 10.0.0.0 255.0.0.0

   default-router 10.10.10.1

   dns-server 8.8.8.8 8.8.4.4

!

!

no ip bootp server

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

ip address 10.10.10.1 255.0.0.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip tcp adjust-mss 1412

hold-queue 100 out

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description $ES_WAN$

no ip redirects

no ip unreachables

no ip proxy-arp

pvc 0/35

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet3

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet4

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname

xxxx

ppp chap password 7 1307050B0A02577B7C76

!

ip classless

ip route 0.0.0.0 0.0.0.0 ATM0

ip http server

ip http secure-server

!

logging trap debugging

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

no modem enable

line aux 0

line vty 0 4

password 7 12090A15435D55

login

!

scheduler max-task-time 5000

scheduler interval 500

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card